Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 600EX II-RT drops link- HELP!


Scenarios I have tried: 


Using Canon Transmitter ST-E3-RT as the master and (2) 600 EX II-RTs as slaves.

Using A 600EX as master and B 600EX as slave.

Using B 600EX as master and A 600EX as slave. 


I get the same result of the slave dropping link. The time varies. Sometimes it drops link in 4 mins, sometimes 10mins, sometimes 20 or more minutes. The only way to relink them is by turning everything off and back on.


All channels are the same. Yes, I have scanned for the best connection as well as every other channel and AUTO.

All IDs are the same. 


Not near a wifi-router or airport, I'm in a row home in Philadelphia. 


Using NiMh rechargeables and using freshly charged batteries for every test. Batteries are about 2 years old. 

I have spoken to 2 Canon service reps and neither of them has any idea what the problem is. I really don't have the money to spend on sending everything in for "repair". 


Any help is greatly appreciated, thanks!





Sadly I couldn't resolve the issue and Canon insisted they couldn't find a problem. I ended up buying new flashes - not an ideal outcome! 

View solution in original post

122 REPLIES 122

After further testing, it's definitely NOT the batteries.  The suggestion of using the I.D. numbers to 0000, or 1111 or 2222 etc. and using a less frequently selected channel was the best solution.  After doing that, I only had one delink over the course of an hour using four 430EX RT flashes being triggered by the wireless master transmitter version 2.  The next test will be to try it with 10 slaves and see how that goes.  

Trying this this week for testing. I am so furious with the drops in 2022. My house is for sure one of the culprit locations I’ve run into. 

What variable are you guys looking at when using something like Wifiman? I downloaded it and don’t understand what function to use to find a free channel. 

On the Wireless tab (bottom, center), you'd be looking at the 2.4 GHz band and some clear space.  I have no idea where Canon gets 15 channels.  There are only 14 total in the 2.4 GHz band and only 11 are technical usable in the North America.  Godox has even more (higher numbered) channels.  Who knows?

I only ever use channel 15.  I also bookend my IDs to either 0000 or 9999 (this is where I think the issue is because there are so many and the tolerance -- distance between IDs -- is probably low).

There is no panacea in the 2.4 GHz band, unfortunately.

I tried channel 15 with no difference


Shame on you Canon for not addressing this. I have called into CPS on the issue and it’s treated like “wow we’ve never heard of this issue before”. Really disappointing for someone who just invested in 3 new EL1’s for 2022. Now I’m STUCK. 

I don't know if you ever watch Bob Davis -- who is a Canon Explorer of Light -- YT videos.  He rave(ed/s) about Canon's RT system (which is a big reason I gave up on 3rd party solutions and went pure Canon) but then readily admits to using RadioPoppers (which operate at ~902-928 Mhz) as a backup for when the RT system, "...isn't quite adequate."

When I first saw this -- searching around for a fix after experiencing drops -- it kinda pissed me off.


P.S. Canon -- whatever that means -- knows about it.


Canon needs to do two things:

1) redesign the transmitter/flash so if link is lost, the user from the transmitter can reset them remotely… or have a setting in the flash that re-seeks connection every minute, 5 minutes, 10 mi utes, etc based on user input. This way, as wifi standards update, it will extend this feature tpinntge flash.

2) offer past canon flash users either an upgrade price or a priority on new refurb models.  This will at least allow users some reason for brand loyaty. These flashes are 5x the Price of the knockoffs… don’t make me think going knockoff was the smarter way. 

#1 isn't possible.  If they could do that, then merely changing the channel or ID yourself would fix the issue.  But you can't.  I can purposely change the channel/ID on a slave, lose link, then change it to the correct setting(s) and it re-links.  I can walk too far away or introduce too many obstacles, lose link, and when I correct for that, it re-links.  But once the link DROPS, there's nothing I can do to get them to re-link -- no amount of channel/ID tinkering works.  I must turn radio off (on the slave) then back on.  It's as if a drop mini-bricks the flash.

I'd love to know the mechanism that's causing the drops.  Is it a frequency shift?  Like a machine designed to play only the black keys of a piano in a pitch black room, if it gets dumped...oops.  And neither the machine, nor the piano, "know" anything's wrong.

I believe Canon has too many IDs -- 10,000!  Other systems, which have IDs, have, at most, 100.  I doubt they're going to do anything firmware wise to fix this as the EX series must be sent to Canon for updates.  The EL series can be updated via the camera.  Maybe when the EL-5 comes out they will offer an update (ID reduction/greater freq spacing) just for the EL series.

I've been having great success with channel 15 and book ending my ID to 9999 or 0000.  This (guessing) limits frequency shift to just one direction.

And lastly, every trigger system in the 2.4 GHz band has issues.  Just spend a little time on a Godox forum!

I too found the most success with Ch 15 0000. 

Has anyone tried the RT noise flash sleeves they sell on B&H? People used to need them for the Pocket Wizard/580ex issue. Noticed someone suggested this on You Tube comments. Experimenting this week. I figured $12 was worth a shot for the time I’m wasting resetting these flashes WAY HIGH UP on light stands during an EVERY MOMENT COUNTS wedding. Before I lose even more money switching my whole lighting setup to Profoto. I am dumbfounded I have to say these things to Canon. 


03/30/2023: New firmware updates are available.

EOS R3 - Version 1.4.0

EOS R5 - Version 1.8.1

EOS 1DX Mark III- Version 1.7.1

Speedlite EL-1 - Version 1.0.2

03/30/2023: Product Advisory for EF50 F1.2 L USM

03/30/2023: Product Advisory for EOS R10

03/28/2023: New firmware version is available for EOS-R5 C
03/14/2023: New firmware version 1.8.1 is available for EOS R6
02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.