cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon ImageFormula R40 Scanner no longer scanning--TWAIN error

jbunshaft
Enthusiast

I have loved my R40 scanner, but now it won't work. I use the Canon-supplied software, both the driver and the CaptureOnTouch software. Recently, when I've tried to use it, I get "An error has occurred with the TWAIN driver. [Error: 80FF0001]" and that's it.

I've tried re-installing the driver. I've tried uninstalling it and re-installing it. I've tried uninstalling all the Canon software and re-installing the whole software package. Nothing has made it work. Someone, please help! Thank you.

1 ACCEPTED SOLUTION

Thanks man, 

this really helped me out! 
I first was thinking about a windows update, as this was the last thing which had changed on the PC.

But as this now poped up a second time and the update is still blocked, the deactivation of the WIA service worked for me.

Thanks a lot for your inverstigation. I also opened a remedy ticket @ Canon Germany regarding this issue.

####################################################################
if you always do what you can already do, always remains what you already are (Henry Ford)

View solution in original post

52 REPLIES 52

shadowsports
Legend
Legend

Greetings,

We understand you are having a problem, but you haven't said what OS and build you are using the scanner with?

What drivers / version did you install?   

Based on your post, it sounds like this is a new problem?  Worked previously (with what OS?) and doesn't work with (what OS) now.  What has changed?

 

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Yes, it's a new problem. I'm not aware of anything changing, which is why this is particularly puzzling. The computer says it's a 64-bit operating system, x64-based processor, running Windows 11 Home, version 21H2, OS Build 22000.469. The driver is what I was able to download from Canon. The computer says it has a driver date of 5/10/2019 and Driver version 1.0.0.0  It says Digital Signer "Microsoft Windows Hardware Compatibility Publisher"

I'd appreciate guidance. Thanks!

shadowsports
Legend
Legend

Were you running windows 10 before, then upgraded to windows 11?  If so, that would constitute a significant change.

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Long ago. They're not in the same timeframe. But with Microsoft's constant updates, that could be related. With that said, how do I get a driver that works so my R40 goes from paperweight back to being a working scanner?

Hector
Product Expert
Product Expert

Hello Jbunshaft,

If you are a getting a driver error, you can try downloading and installing the twain scanner driver using the link HERE. We would be happy to assist with the issue. To provide some feedback or some troubleshooting steps, we would need some additional information. If you could reply to this message with the information below, we can provide some assistance.

  1. Did the issue begin after performing any updates?
  2. Do you have any other scanners connected to this computer? 
  3. What security software are you using?

Thank you, Hector! I'm glad to hear from someone from Canon. That at least gives me hope we can get this fixed.

Honestly, I don't know if there was an update right before this started. It seems like Microsoft is always doing another update, but I'm not actually aware of one having happened before this issue started.

No, there are no other scanners. This is my one and only. And since I saw other people say something about a USB hub, no hub, either. I plug the scanner directly into my computer.

For security, I'm using McAfee Total Protection. That's not new, either (although if it had some silent update, I suppose that could be, too).

Thanks for any help you can offer!

Jess

GettnBetter
Apprentice

We have this same issue.  We have half a dozen of these devices.  They all fail in the same way on every Windows 11 computer we have.  Our service tech's have tried everything we can think of.  What we find is we have to uninstall the drivers and unplug the scanner.  There's a TON, crazy plugins for apps we don't have too.  Then reboot and re-install and the scanner will work for a day or two, then again, twain error.  Both the Canon scan app and the windows scan app fail once this happens.  Not a single R40 works with Windows 11 for us, not even fresh loaded Windows 11 computers, they fail in the same way.

 

I've seen reports at Microsoft that setting the “Windows Image Acquisition” service to automatic and starting it seems to work but we haven't been able to verify this yet.

I tried changing the Windows Image Acquisition setting, too. I think I've read all the suggestions online. No luck. I'm very frustrated. I wish the Canon people would get on this. Yes, Windows changed. That's the world we're in. No reason that means the scanner should stop working forever. It needs some kind of patch. I wish you luck getting your scanners up and running!

Nice to know we're not alone here.  I agree, some kind of patch is needed.  We're dead in the water here and might have to abandon Canon as a supplier if we can't get something that works soon.

Avatar
click here to view the gallery
Announcements