Showing results for 
Show  only  | Search instead for 
Did you mean: 

CanoScan LiDE 400 "Cannot Communicate with Scanner" Error Message


I just received my new CanoScan LiDE 400 tonight. It installed with no problems, turned on with no problems...but now I'm constantly getting the error message


"Cannot communicate with scanner for these reasons: 

-Scanner is turned off.

-USB Cable is disconnected.


Please check and try again. 

Scanner driver will be closed.


Code: 2, 156, 33."


I have tried EVERY "fix it" I've found on Google and nothing is working. I've changed my computer to Power Saver battery option -- didn't work. Changed the suspension on the USB port...didn't work. Yes, I'm using a 3.0 USB port on a Dell Inspiron 17 5000 series laptop. I have Windows 10 and I think that's the #1 problem --- Windows 10.

I've installed two different drivers that's supposed to work... didn't. I've installed it via the CD-ROM, didn't work...uninstalled and re-installed via the website... didn't work. Nothing is working. 


Should I just return the scanner and go with a different brand of product? I already have trouble with my Canon MG3500 series printer so.. I should have known better than to buy a Canon portable scanner. 



Hi BreccaM1993.


Since the LiDE 400 uses the USB connection both for communication and for power, try plugging in the laptop to external power when using the scanner.  Usage of the USB connection when running on battery power can reduce the electricity (and thus also the USB signal strength).


Some USB 3 ports may have backwards comaptibility problems, so if the scanner still has trouble, try switching to a different USB port.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


I see another person has had this code error which you gave advice to.


My problem is slightly different in that I am not using a laptop and so your suggestion is of no help to me. Also it was working fine for months and I was in the middle of scanning and it just stopped.


code: 2 156 33


Canoscan lide 400


Windows 10


I have tried all the suggested solutions on your 'error messages' page to no avail.


Please help.

I had the same issue with this scanner in Ireland. I rang Canon and gave them the error codes and they confirmed it is a fault and advised me to return it to the retailer. 


I finally returned my LiDE 400. Hoping they fulfill a refund. It just absolutely was not compatible with Windows 10, no matter what they said. I even posted a review telling others with Windows 10 to steer clear of the product and of course, they deleted it. I've had it with Canon.. the customer service has been horrendous, the products are getting worse as years go by.


according to support the problem is:

Some of the LiDE 400 devices had the scan bar installed backwards and were not caught before they left the manufacturer.
if you plug it in and when it finishes warming up, the scan bar is at the tail end (where the usb connects) this is what the problem is
Return it for exchange if you can or call support and if you still have reciept they will ship a replacement.

same problem here with my LiDE 300: the scan bar at rest is not at the button end but at the tail. I wonder if Canon could confirm this is part of a defective batch and return is for free, even if past the warranty. 



I had the same problem and after some experimentation found that uninstalling all the scanning software and drivers and then reinstalling after a reboot my scanner started working again. Hope this helps someone


Is there any solution to 2 156 33 error?


I have a scanner with the scan bar at the tail end. When I plug it in, the scan bar moves to the front, flashes when going back 1 inch, and then returns to the previous position (tail end). I don't have a warranty on this one and would appreciate any hints. Thanks.

Product Expert
Product Expert

Hi hexon,


Please disconnect the USB cable from your scanner and then toggle the lock switch back and forth a few times, leaving it in the unlocked position.


Please open the cover and make sure that the scanning element is on the side with the buttons, not the hinge side.


Reconnect the USB cable an attempt to scan.


If the error persist, please contact our support group using the following link:







Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.