Canon Community Canon Community
 


Reply
Highlighted
Occasional Contributor
Posts: 11
Registered: ‎12-30-2019
Accepted Solution

Pro-100 and iMac (Catalina?) Not speaking

I have been attempting to sort out some issues printing from my iMac with my Pro-100. FOr background -

iMac running Mac OS 10.15.3 beta (Catalina), connected via Linksys EA7450 router and ethernet cables.

 

Following suggestions here, I recently updated the Pro 100 driver on my iMac, now 16.40.1.0. Prior to the driver update, I had intermittent issues with the computer "seeing" and communicating with the printer, but re-starting one or the other seemed to resolve the issue. Since installing the latest driver, I cannot get the computer and printer talking (as checked by opening the printer status window and attempting to check ink levels.)

 

I'm stymied. Suggestions? Similar experiences? Printer driver, or Catalina, or something else? Thanks in advance.

Highlighted
Occasional Contributor
Posts: 11
Registered: ‎12-30-2019

Re: Pro-100 and iMac (Catalina?) Not speaking

Well, I THINK I have the connectivity issue resolved. I forgot that when updating a printer driver, it's good practice to have the printer turned off, and generally, disconnected. The Windows version of the driver install software reminds the user of that little detail, the Mac OS version does not.

 

Looks like I'm good to go - as soon as I replentish some ink supplies.

Highlighted
Product Expert
Posts: 3,117
Registered: ‎10-16-2012

Re: Pro-100 and iMac (Catalina?) Not speaking

Hello.

 

If the printer is being used on a network, make sure that the Canon IJ Network version is being added to the Mac instead of the AirPrint/Bonjour version.  Perform the following:

 

 1.  Click the Apple and choose System Preferences.
 2.  Open the Printer and Scanners menu.
 3.  Highlight and delete any copies of the Canon Printer listed on the left by clicking the minus (-) sign.
 4.  Click the plus (+) sign and look for an option that says "Add printer or scanner".  Click this option.
 5.  In the next window, click Default on the upper left corner.  Wait a few moments, then highlight the Canon IJ Network version of the printer. 
 6.  Click Add on the bottom right corner when it becomes available.

 

Once this has been done, try printing to test the connection.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Highlighted
Occasional Contributor
Posts: 11
Registered: ‎12-30-2019

Re: Pro-100 and iMac (Catalina?) Not speaking

Thank you for the tip!

 

In short - once I found out that the printer had to be turned off and disconnected to successfully update the driver software, I found the IJ version and that is what I used to re-install the printer.

 

A gentle suggestion - the Windows version of the driver install package "reminds" the user to turn off the printer and disconnect the cable. Could not the Mac version be changed to provide the same reminder?

Highlighted
New Contributor
Posts: 3
Registered: ‎09-20-2019

Re: Pro-100 and iMac (Catalina?) Not speaking

I'm running Mac OS 10.15.2 (came installed on my new iMac bought in dec 2019).  Utilities such as alignment, cleaning, etc. does not work.  Followed instructions to access utilities and when located, the Pro-100 utility carried an Apple message that it was not compatible.

 

Print driver apparently works fine.

 

Any suggestion about what to do?  This is serious!

 

 

Highlighted
Honored Contributor
Posts: 6,408
Registered: ‎11-13-2012

Re: Pro-100 and iMac (Catalina?) Not speaking

[ Edited ]

Welcome to the forum PrintGeezer.

 

1. Go here: 

 

https://www.usa.canon.com/internet/portal/us/home/support/details/professional-large-format-printers...

 

and download the 16.40.1.0  printer driver.

 

2. Go to Printers and Scanners and delete your current printer.

 

3. Install the new driver and add the new printer. Be sure to wait until the IJ Series version of the printer shows up. You don't want to select the AirPrint version, which is usually what shows up first.

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LR Classic
Highlighted
New Contributor
Posts: 3
Registered: ‎09-20-2019

Re: Pro-100 and iMac (Catalina?) Not speaking

[ Edited ]

John, thank you; your process worked, and I have access to the printer utilities as well as a more robust selection of options in the print window.  The key from my perspective was deleting the existing Pro 100 driver from my System Preferences window (actually before installation of the new driver) , then explicity adding the printer (I chose the USB version) using your steps.

 

I owe you a beer ... maybe two. 

 

Paul

Highlighted
Occasional Contributor
Posts: 11
Registered: ‎12-30-2019

Re: Pro-100 and iMac (Catalina?) Not speaking

I was hoping John would show up (figured he would!) and shed insight. I thought that would be the magic elixir, same as it was for me, but wasn't 100% sure.

 

By the way, in case you are feeling adventurous - I just today got a banner that MacOS 10.15.3 public beta 2 was available, and I blithely downloaded and installed. So far, so good...

Highlighted
New Contributor
Posts: 3
Registered: ‎09-20-2019

Re: Pro-100 and iMac (Catalina?) Not speaking

Thx, but I think I'll wait until Apple releases the real version.  There's so much going on in this "black box" behind the screen I'm looking at right now that I don't think I'm up for introducing new unmanagable variables.....

Highlighted
Occasional Contributor
Posts: 11
Registered: ‎12-30-2019

Re: Pro-100 and iMac (Catalina?) Not speaking

While all seems to be well for me, I can completely understand! Best wishes -

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement