cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA PRO-10S Feeds Paper But Doesn't Print

Richie22
Contributor

My Pro S printer feeds paper through the printer but does not print. I am attempting to print from the latest version of Lightroom using Print Studio Pro Ver.2.2.3 (Windows). I have reinstalled this Plug-in but still no printing.

This is the first occasion I have had this problem.

I would appreciate any help.

1 ACCEPTED SOLUTION

Hi Karl. I don't normally use PSP since I never found it to do anything that I couldn't do in Lightroom.

I did just try printing from both LrC and Canon DPP4 using plugin printings and got the same blank sheet as you did.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

View solution in original post

12 REPLIES 12

SamanthaW
Moderator
Moderator

Hello!

To have a better understanding of your issue, please let everyone know the model of the printer you have, as that doesn't appear to be a full model number.

If this is a time-sensitive matter, please check out your other support options here.

Thanks! 

Apologies, it is a Pro 10S

Model PRO-10S series XPS

KarlKrueger
Enthusiast

I just had the same problem with my Pixma Pro-100 also using Lightroom and the same plug in. After I wrote my post I stumbled upon yours here. 

jrhoffman75
Legend
Legend

Does it print if you don’t use PSP?

What version Windows?

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

jrhoffman75 - good idea, I kept thinking the problem was printer - it is not! I went from Lightroom, opened up the same photo in Photoshop and printed from there. It worked!!! So the problem doesn't seem to be the printer but instead PSP. I did not do anything with PSP but of course Windows regularly updates itself (I've got the most recent version of Windows 10 which had updated maybe 2 weeks ago). I did not try printing any photos since then until I came across this problem just now. I believe the problem lies in this latest Windows update OS build 19044.2364 and probably Canon needs to work with Microsoft to correct this. It sure is more convenient using PSP rather than switching to PShop for each print.

John I see you use PSP. Do you also use Windows 10 and if so aren't you seeing this problem?

 

Hi Karl. I don't normally use PSP since I never found it to do anything that I couldn't do in Lightroom.

I did just try printing from both LrC and Canon DPP4 using plugin printings and got the same blank sheet as you did.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Richie22
Contributor

I have been unable to get PSP to work either with Lightroom or Photoshop with latest updates of all apps including PSP. I have given up and accepted John Hoffman's advice and print from LrC direct.

It is a pity as I found PSP very user friendly. I would be surprised if Canon is not aware of the issue. Hopefully they resolve the problem or advise users that they no longer support PSP.

This issue has been a topic in several threads. Problem seems to be related to using the XPS driver. The latest Windows updates seem to have broken it. The regular driver works fine.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic
Avatar
click here to view the press release
Announcements