cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pixma G5020 Print Driver Will Not Install

galfaqih
Apprentice

I recently purchased a G5020 printer and cannot install the driver. I am running Windows 11 and have executed all the following steps using "run as administrator" as well as logging in the admin account itself, using a clean reboot, and finally disabling certificate checks; rebooting between each effort, all to no avail. The driver Windows decided to install does not provide sufficient features to effectively use the printer. I require a native and functional driver that will install without errors.

Using the Canon Setup program:

  • Select “Start Setup”
  • Select “Next” on “Before You Continue” screen
  • Setup acquires information
  • Select “Yes” for License Agreement
  • Select “Agree” for service screen
  • Setup goes into processing mode
  • Setup finds printer and asks if wired LAN is OK
  • Select “Yes”
  • Installing Printer Driver
  • Installation failed. Click [Back to Top] and restart the setup.

This occurs every time without fail, and I tried it at least a dozen times.

Using the Driver Setup program:

  • Welcome screen select “Next”
  • Select “Place of Residence” USA and “Next”
  • Select “Yes” for License Agreement
  • Installation begins
  • Error occurs “An error occurred while files were being copied. : 0001 0002”
  • Select “OK”
  • Select “Finish” to complete setup

This occurs every time without fail, and I tried it at least a dozen times.

I have also tried installing the driver file(s) directly via Widows Update and manually browsing directly to the file G50006.inf several times, always ending in failure stating "certificate revocation by issuer."

4 REPLIES 4

Stephen
Moderator
Moderator

Hi! I'm not a tech, but I want to make sure you've obtained the most current software from our site at https://canon.us/ijsetup 

The site will walk you through the process & have you download the best option for your Operating System. If you've done that, and it's still not working, just let us know! 

galfaqih
Apprentice

Thanks for the tip. I did that first. Running Win11 and downloaded the latest from the Canon website. Am quite familiar with technology and usually start with "is it plugged in" knowing many times the simplest solution is the one. This one however is a real head scratcher. I have installed other devices successfully so I believe it is the Canon driver or installer, particularly since when trying to install the driver file alone, I got a certificate revocation error, which could be the problem in the installation software which likely does not interpret the error precisely.

Hi,

At this time I recommend you reach out to Canon support. You will need to register your Canon gear HERE to access additional support options.

We look forward to hearing from you. 

galfaqih
Apprentice

Thanks. I did that. After the tech had me execute all the steps I described earlier in this thread with the same results, he said "it is recommended that either your computer manufacturer and/or Microsoft is contacted for further assistance," despite the fact I have since installed other drivers and the Canon driver is the only one I have a problem with. I believe all I need is a G5020 Canon driver file with a good certificate. I am at a loss for the moment and not sure what the next step will be, though I may try to contact MS again.

Avatar
click here to view the press release
Announcements