cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

No Wi-Fi connection with my Pixma 920 series using T Mobil 5g router

LDP
Apprentice

I had no problem with ATT universe router which has a WPS button to connect. I decided to which to T Mobil 5g network which the router not connect to Wi-Fi. Although the printer recognizes my router I cannot enter the password which is required for their router. I went to the standard and advanced settings but still not able to enter the password. I keep getting that nagging message saying I need to check my setting and mt password. Can anyone help me out?

Thanks

1 REPLY 1

ArthurJ
Product Expert
Product Expert

Hi,

If the TMobile device they gave you is running WPA3, then you wont be able to connect the printer or get to the password screen during Standard Setup. 

I recommend changing the router settings to WPA2 and then try using the standard setup to connect the printer. At this point your network will appear and you will be able to enter your password and connect the printer. 

Once the printer is connected to your network, you can set the device back to WPA3. 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Avatar
click here to view the press release
Announcements