Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF644cdw - Shows Offline from MAC


I have been struggling to get this printer to work consistently on my network from my MACs. Most of the times when I try to print, I get an error.


Opening the Settings --> Printers and Scanners --> Canon 644c,

The banner says that the printer is offline.

Under the print job I get the message Priner - Unable to find printer


  • The printer is on
  • The printer is close to the wifi router
  • I am using a reserved ip address for the printer (so that I have the same ip each time)
  • I can access the printer from the browser using the ip address
  • I was able to print from a moblie phone
  • I can scan from the Canon Print Business mobile app
  • I have installed the latest drivers from the support site on the PCs 
  • I have tried to use the Airprint driver as well as the Canon Support site drivers

None of the macs can consistently print using the print function. 


Anyone else face the same problem?



Everyone is asking the same question and then you answer each time, would be better use of time for everyone. Thanks! 

This is the usual answer from Canon but it’s bogus: I have Windows based systems on exactly the same network condition that work just fine. This is a Mac-specific problem.

Yup - I think its specific to the Mac driver.  Setting the IP address as static was my -working- solution.

Well, after all this, I deleted and reinstalled the printer, and it worked. So I learned I could do that without the computer "forgetting" the printer. Thanks everyone for all the suggestions!

..working until you lose power again. Consider making the IP address as static as suggested.


I've had this problem several times over the last few years on my MF644Cdw; it happens every time the power goes out, or I upgrade my network. I've tried EVERYTHING listed above, wirelessly and wired and I've purchased multiple replacement printer cables thinking they were the issue. Some of the options worked after being on the phone with tech support for an hour or more.

This time, I factory reset my Mac (using OS 10.15.7) and I watched YouTube video imageCLASS Multifunction Five Line Display Wireless Setup Video for Macintosh (MF113w) which is linked on the Canon website. I noticed nothing different from the steps I'd made previously until  5:13-5:33. In the past; I didn't Add my printer because it automatically populated so I didn't have the opportunity to highlight my printer or select my printer driver from the Use dropdown. This was the simple answer to my problem. My drivers had been downloaded but weren't in use causing my printer to show as offline.

The Solution: System Preferences/Printers & Scanners

  1. Highlight your printer
  2. Click the - sign
  3. Click Delete Printer
  4. Click the + sign
  5. Highlight your printer when it populates
  6. Click in the Use field
  7. Select your printer driver
  8. Click Add

I've likely completed this step with tech support on the phone and don't recall, but it worked for me this time. I hope it helps you.


Thanks for the details!



What made the whole problem go away is that I did this:

1.  Setup the printer with a static IP address (don't use DHCP).  It doesn't matter if you're printing wirelessly or have it connected via ethernet.  This is critical because you'll need the static IP address later in these steps.  After you have done so, restart the printer and ensure that it's using the static IP address.

2.  Download the latest drivers from Canon's website.  Install them.  (YMMV whether or not this will all work when trying to connect via AirPrint from your Mac, I used Canon's drivers.)

3.  Remove the printer from MacOS.  Remove the Fax too if you have an entry for that.  Reboot if you want to, never hurts after doing something like this.

4.  Add the printer.  DO NOT use the first tab where it auto-detects and finds it via Bonjour.  Instead go to the 2nd tab (that looks like a globe) and add it using the IP address that you established in the previous step.  IPP is the default protocol, keep it.  Then you MUST select in the "Use" field the printer driver you installed in the previous step.

5. If possible, I'd also recommend not using WiFi as the way to access the printer on your network, use an ethernet cable to connect the printer directly to the router.  (I have not done this but it is always recommended!)

6. You can also configure the printer's WiFi settings (if you didn't listen to me in step 5) to disable the printer's WiFi power management setting (turn it off), that was highly recommended in another post and as far as I can tell it couldn't hurt.

As far as I can tell, step 4 is important because it tells the driver "always find the printer at this IP address" and bam, even when it's asleep, I can print to it from my Mac, even via WiFi, when I couldn't before.
This raises the question "what about my iPhones and iPads?" where you don't actually install any print drivers and it relies on AirPrint?  I don't know, I haven't toyed around with that just yet.  But these steps got me printing even after the printer went to sleep and would otherwise have shown as offline.  I hope this works for you.