Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF644cdw - Shows Offline from MAC


I have been struggling to get this printer to work consistently on my network from my MACs. Most of the times when I try to print, I get an error.


Opening the Settings --> Printers and Scanners --> Canon 644c,

The banner says that the printer is offline.

Under the print job I get the message Priner - Unable to find printer


  • The printer is on
  • The printer is close to the wifi router
  • I am using a reserved ip address for the printer (so that I have the same ip each time)
  • I can access the printer from the browser using the ip address
  • I was able to print from a moblie phone
  • I can scan from the Canon Print Business mobile app
  • I have installed the latest drivers from the support site on the PCs 
  • I have tried to use the Airprint driver as well as the Canon Support site drivers

None of the macs can consistently print using the print function. 


Anyone else face the same problem?



Thank you! I am running Big Sur 11.2.3 on my MacBook Air.

Is the IP address to the printer dynamically assigned? If so, it probably changed with the power glitch when the router rebooted.  To avoid this in the future, set the address to be static in the router configuration page.

I found the IP address but don't know how it's assigned. Please advise.


Also, I went to the Canon page and downloaded the latest drivers that work with Big Sur 11.0, but I'm not sure how to get the printer to access them.  

I don't believe it's a driver issue as we recently updated to Big Sur also without a problem. To set the address as static, you have to log in to your router webpage (easy to google) and set it within there. Also, the printer setup on your Mac needs to know what that address is. I'm not a mac guy (its my daughters laptop), so I don't know the steps from memory, but that's what I needed to do in our situation - FWIW. Hope that helps.

Thanks for the suggestions!

I have had this same issue since day 1 with this printer. It consistently works fine from my Windows systems but has always failed to work with any of the household Mac computers (2 Mini’s and 3 MBP’s) and the common denominator is the Mac driver. We have deleted and reinstalled the driver so many times it makes my head spin and Canon support has just pretended they know nothing of this issue and it’s never come up before. It has persisted through several Mac OS/X upgrades and is beyond frustrating.
My network is mesh and solid throughout the house; I can print from my Windows machines from anywhere and Macs nowhere.

I'm having the same issue with my brand new MF743Cdw on two different versions of MacOS (11.2.1 and 10.15.7)


One difference with mine is that the printer is connected via Ethernet, not WiFi, so there's no way it's a WiFi signal issue.


I have no issue setting up the printer, but it goes offline after the printer goes to sleep and the Mac can't wake it up to print. What's really odd is that the scanner still works even though the printer says it's offline. I can switch to the scanner in Settings > Printers & Scanners. But even scanning something doesn't bring the printer online.


I've tried resetting the printing subsystem and I've removed and readded the printer numerous times.

Product Expert
Product Expert

Hello SGUF Fan,


If the Mac is connected to the network via ethernet and you can scan but can't print, it will usually point to the driver being used for the printer connection. I would suggest starting by downloading the recommended driver for the MF743Cdw using the link provided HERE.


Once the drivers has been installed, you can remove the printer from the printers and scanners list using the - at the bottom of the printer list. Once it has been removed, you can click the + to add the printer back.


When adding the printer back, make sure the USE box near the add button is not set to the Mac's generic airprint connection. You can click the dropdown and select the driver that has the printers name attached to it. If it does not appear, you can click on select software and search for your printer model number. Once it has been added using the proper driver, the connection should be more reliable.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.



Thank you for your response. I was able to delete and re-add the printer much like you describe.

Hi Canon support,


Why don't set up an easy to find trouble shooting page with clear instructions for offline printers, with photos and step by step instructions or does a page like this exist? Thanks!