cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF269dw II AirPrint doesn't work unless the machine is awake

dwhite
Apprentice

I recently purchased the ImageClass MF269dw II. I need to be able to print over AirPrint from my phone. I can do this when the machine is awake, but it doesn't show up as active or as an available AirPrint printer when it's asleep. When I wake the machine up, it immediately appears as an AirPrint destination. I connected the printer to my Eero WiFi network. I turned off the power save on the network connection. It's connected via DHCP, but I previously tried a static IP address. Neither one worked when the Canon was asleep. 

I also have a Brother color laser that always appears on my network as an AirPrint destination. It's just the new Canon that needs to be awake to print. I also noticed on my Mac that the Canon printer shows as offline, but I can still print to it. I don't have these problems with my Brother printer. I'm disappointed in the Canon but hope to find a solution. 

3 REPLIES 3

jrhoffman75
Legend
Legend

I have a Pixma Pro-100 connected via Wi-Fi. It also needs to be powered on for the printer to be recognized. The printer has a power-off timer setting in the driver, but specifically states that printer will remain always on when connected via Wi-Fi. That appears to be the Canon design basis. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

shadowsports
Legend
Legend

Greetings ,

Has John pointed out he might be able to make changes to the printer's power management settings and for keep alive or awake.

I would also try assigning the printer a static or reserved IP on my network.  This can be done on your wireless router.  It only has to be done once.  

 

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It

dwhite
Apprentice

I am using a static/reserved IP, but it still isn't visible while the machine is asleep. The max I can keep the printer awake for is 60 mins, but that is wasting energy. When in Energy Saver mode, it's like it doesn't exist. I don't get it. If this is a feature, I'm returning the printer as soon as possible. It's not functioning the way my Brother printer does. I need to be able to print without waking it.

Avatar
click here to view the press release
Announcements