Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100



I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575

Good luck,

I am dealing with Canon Canada and they are certainly not willing to do the right thing with a little nudging. The problem is that most people don't realize there is a problem until after the warranty has expired. Canon wants $160 from me to repair- actuallly that amount is just to send it back to them for repairs. I'm stuck with a camera I bought two years ago for $400 and hardly used that doesn't work and they want me to shell out $160 more. I'm more than upset at this.

To the person who filed a complaint with the bbb ( voodoo), can you tell me which office you filed against. I am searching for the head office in Mississsauga Ontario and they are not listed. Did you file locally?

That is a shame...good luck and I hope you get a satisfactory resolution.

I did a quick look at all the Powershot forums posts and this topic looks like the second or third most viewed problem topic in the Powershot forum. The only higher ones with dif model cameras were a battery drain thread and maybe a wifi connection problem thread ?



this is where BBB sent the complain:


Your complaint has been applied to the following business:

[MOD NOTE: Address removed per FORUM GUIDELINES]


Hope this helps.

voodoo I'm happy for you, but now I guess I have to file that BBB complaint.


If you cannot provide the entire address per guidelines, could you provide the State and entire name that you used? There seems to be a lot of "Canon" businesses out there.


Thank you.

Canon S100 camera
I too am having an ongoing issue with my S100 ( a 46... Series) Since just after the warranty period, pressing the shutter release button will result in a focus, but then no further click to record the image. As I had just paid 500 for the camera, and the fee for checking was very expensive, I decided to look online for possible issues. Well, there was no shortage!
My best to date solutions:
1. the low tech dry bag solution.
I carry my camera in a ziplock with several small desiccant packs, as the issue seems to be related to high humidity. Not very professional looking, but it works, although today it was for only one shot, then the issue recurred. I can only relate symptoms, as I am no technician, just a frustrated consumer.
Solution 2:
My husband has a similar Fujica, so we share it when on vacation in humid climates, or during much of the summer in the area where we live. Not recommended for marital bliss!

My previous Elph worked for years and many thousands of fabulous shots. Canon says they have no recorded issues with the shutter release in the S100 46... Series. Anyone else have this issue (whatever it is) in this series?

I was to told by customer service this morning (in Canada) to do what I had to do, so it's off to the BBB site!

Yes as you see this thread is 9 pages long and still what you have to do for sure and good luck. I would need to get my hands on one these this same problem but Im pretty I have a pretty good idea as to what it may be.


I sent my camera to Canon repair in Vriginia and just received a repair bill of $170 to fix the shutter problem. What a joke!


Our two year old S100's shutter button started acting up about 6 months ago and now it will not take a picture. It will still focus when the button is pressed halfway. 

Serial  42203200XXXX