Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100



I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575

I have seen and repaired as a hobby similar problems with older Canon cameras and the shutter release not working, It focuses but does not shoot. In my experience with several older G models was the tab on the frame that holds the circuit board on which the shutter release/focus button is mounted was bent. Bent ever so slightly enough as to not allow the second stage of the switch to close. Or bent slighty enough so it may work intermittently. When that starts happening ones reacttion might be to press even harder which makes it worse. I never worked on a S100 and I dont know if what I said applies, physically. The reason I replied is it just sounds familiar and similar and I think they have to be sent back to Canon for repairs.

Interesting idea that it is a physical problem. Once it starts to work it will continue until turned off or set aside. I always felt it was a software problem. But, no matter what, if this is common, why doesn't Canon come up with a free fix? It will cost me $ 150 to get it repaired....hard to invest that in a 2 year old camera. And without them agreeing to fix it, I will divest myself of all Canon products. I am sure others must feel this way...


Thank you for all the posting. This thread help a lot. I am hitting into the same shutter release problem. S100 just don't fire again on full shuttle pressed. It only work when running through video recording or when the camera warm up.


I read some of the post, sending back to Canon doesn't solve the problem or it is just for temporary. I still have a few months warranty left. I am thinking should I send it back for repair or not if Canon still don't know how to fix this problem permanently. Any feedback/comment is appreciated. 


I sent the camera to Canon. It took a week and about $50 without warranty to fix the problem. 


I haven't had a problem with it since, and this was around 8+ months ago.


I was given a thin piece of circuitry that clearly ran along the top of the camera near/under the shutter release button, that I would assume connects it to the shutter mechanism itself. 


(I bought this camera in the US. However, I was living in Thailand when this issue came up for me. Not wanting to deal with international mail issues, I chose to forego my still active warrantee in the US and send it to Canon Thailand. Works great now.)

glad to hear that is working for you.  Here in Canada, they asked for $160 so it is not worth getting it fixed...still haven't heard anything from anybody at Canon on this forum who might facilitate getting this fixed. 

I've had this problem for about the past year with my S100.  It started sporadically and now the camera is basically useless.


It only takes a picture 1 out of 1000 times I press the shutter and then only when holding it down for a very long time (20 seconds to a minute).


Canon, when are you going to admit that there is a huge flaw with your camera.


Has anyone come up with a solution or had success getting this fixed?

I've seen and fixed this on other Canon cameras it is most likely the circuit board under the switch had been deformed or bent from pushing the shutter release button to hard, bumped or normal use. Especially if it is intermittent or got progressivley worse. It is an easy fix the work is in getting to it to reshape/rebend the mounting and or board. Basically the board with the actual switch on it moves to far away from the mechanical shutter button. You may be able to get the service manual if you are handy with this sort of thing and repair it yourself.


I have an s100 that's 18 months old and not been used much at all. 

The shutter release does not work at all propertly with exactly the same problem that many people have described on this forum. The camera does not take a photo when you press the shutter. Occasionally, though often after 10 seconds or so, when the moment has passed it will release. This renders the camera basically useless and very frustrating. 

Unless you look after your customers and make decent products they will defect to other brands. There are lots of others out there. 


Maybe this is a cost saving measure, cutting down on customer service. Canon makes little money in compact cameras and the share price has been doing poorly 


I think the company should have stronger principles and address what is clearly an issue with regard to this product. 


The serial number on the camera begins with 45 for what it is worth. 


Please issue a recall on this issue beyond the warranty period. 

I have the same problems with my powershot s100 as stated above, i.e. even though I press the shutter release no picture will be taken. The problem occured randomly several weeks ago and now the problem occurs in 95% of all cases. I already downloaded the latest firmware and reset the basis settings. Unfortunately, it did not solve the problem.


Any ideas how to solve this? What are you doing now with your cameras? 


Best regards,

Powershot S100


I am sad and happy to say that Canon repaired our camera for free, after the warranty was over.


Sad: because we had to file a complain to the BBB in order for them to take us seriously and do something, free of charge


Happy: because we received our camera back yesterday, and with our tests it is working fine, hoping it'll last like this and not happen again a year from now.



click here to view the gallery