Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100



I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575

Congratulations. Mine does not.


Don't feed the trolls.


Since my last post I've put the S100 back in it's box and bought another camera. I'd still like to know why it would go so drastically wrong only 18 months into it's life though.

While it is very unfortunate that you all have had problems with your S100s I was trying to point out that it is not a universal occurance. There are many thousands of these cameras out there whose owners are completely happy with them.

Yeah, I was completely happy with the S100 too. Until it stopped working completely and found this forum that made me realise it is a common problem that any time soon can happen to anyone, including you.

Regarding the comment made by Gary S., point well taken that most s100 cameras may be trouble free and the camera takes great pictures.  But a problem is a problem, even if it affects only a fraction of the users.  Our camera is a lemon.  First it had the lens retract issue that Canon acknowledged and fixed for free.  Now this second problem that required repair by Canon.  In the age of Six Sigma, Canon should be stepping-up.  Their response is unimpressive, suggesting that they either do not know how to fix the problem or just do not care.

Gary S, simply a troll! Hope you camare never fails!

And CANON it is time you accept there is problem with SOME ( to make the troll happy) of the S100

Yes. Just because only a fraction of  S100 owners are experiencing this problem,  that does not invalidate their concerns. It is not a cheap camera and these problems should not occur with any of them, no matter if it is 10, 100, or 1,000 cameras.


I'll be testing this out later today, but I may have found a solution to the issue (at least in the case of my s100).


Menu > Shooting Settings > Blink Detection - OFF


Geez I hope it's something as stupid and simple as this.


Hi sedphx


where did you get this info from?

I had Blink Detection disabled on my S100 when the problems appeared.
I set to to ON and tried it, then back to OFF and tried it. But problem persists in both modes

Thanks for you input though






I just stumbled across it going through my menu settings.  It was on (perhaps by default?) and I changed it to OFF.  It does seem to have helped in my case.  I just returned from a few hours at the Acropolis in Athens and for the most part my S100 was snapping away.  I was shooting mostly in P mode -- that seemed to work best.  In Av mode at 2.0-2.8 it was very laggy again.  I only shot jpeg -- didn't think to try shooting from RAW frames.  We'll see.

click here to view the gallery