Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100



I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575


Just FYI for any Canadians with this problem.  I called Canon Canada today and the replacement part (CM1-7226-000 "FPC ASS'Y TOP") is no longer available.  The CSR said it was discontinued in January 2016.


I guess if Canon USA still has it, it could be ordered and shipped to an address for later pickup for those that head down to the States.

see post 474

The same date, Jan 2016 was when the repair part was not availble in the USA as well.

Just to add my voice to the chorus...


My S100 failed in the same way as everyone elses - shutter button. I had the same temporary success with cleaning the shutter switch. I managed to get the replacement board from this week (September 2016) - all working again! Thanks to those who did the research into what the replacement part was and where to get it from.


It is a shame Canon don't pick up on this one. They were fantastic with my Canon Powershot A85 - I bought it in 2004 and they did a free a replacement of the sensor in 2010 to correct a manufacturing defect, well out of the warranty period!

Add me to the list of shutter button quit working at full depress (still focuses).  Camera is c 3 years old and treated well and never dropped, etc.


Serial number also rubbed off- another poor quality choice.


Called Canon and as expected, no help.



-ordered a Sony Cyber-Shot DSC-HX90V Wi-Fi GPS Digital Camera as I am going on a long trip and need a reliable camera with GPS and Canon moved to the bottom of my camera list now.  I complain by my microscopic hit to Canon's sales by buying Sony and posting my comment.


-I'm ordering a new button and giving that a go.  I had an early (but out of warranty) screen failure (digitizer), on a Garmin Zumo 340 motorcyle gps.  Ordered a new screen and digitizer from Ebay for c $25, and working fine again.  That was a pretty easy install.  Just takes the right screw/torx drivers, and patientence with the tiny ribbon cables.

Hopefully have the same results with the S100, although it will go to a family member when repaired given the Sony will hopefully be a noticeable nicer camera.


Update- I was waiting for Canon to call me back about getting a new shutter button.  So, I decided to pop the shutter button off with an Exacto knife.  Pulled it off, blew some compressed air on it, and pressed the button back on (there is a tab to line up).


It works fine now.  BUT, lets see how long.  So, the switch does not seem to be getting fully depressed (wear, manufacturing issue, dust, etc).  


But, still going on the back shelf as I've got the new (and hopefully materially nicer) Sony now,



I have spoken to Canon repair centre (uk) and hlehmann and canon say there is no known fault so it is a chargeable repair, and hlehmann say it is actually a known fault and Canon have taken the fault off their list for some reason...(up to you to decide why, but guess you won't be wrong), but he is repairing my camera foc as he knows how to claim it on canon warranty...... shame canon have to be so dishonest, and great that there is still someone who knows the truth 🙂    Great little Camera, but doubt I'll be buying from Canon again.  Shows how your values and culture speak louder than your product.


After pressing down the shutter about10 times in quick succession, the shutter works for a while. It is only a  temporary remedy. Obviously it is a manufacuting defect becasue there are so many complaints. Canon S100 takes good pictures,but after this experience, it is difficult to continue be loyal to Canon. 


You might try this fix. It as worked for many of us, but for most the fix is temporary. Get  a product called "Deoxit". You can find it on Amazon. Use the D5 spray, followed by a few drops of the Gold. Start by just spraying around the shutter button (camera off) and after drying for 10 minutes power on and try the shutter. If that does not work, get a tiny phillips head screw driver, take off the from cover, and spray a short squirt in the shutter area. That will most likely do it, but if it doesn't -- take off the rest of the cover pieces and work the spray directly into the switch. I hope this works for you. Use extreme care (clean work surface, cup for screws etc) during surgery. For me this fix lasted for a few weeks. I eventually ordered the repair part and replaced the shutter switch (see earlier posts) and that fix has lasted more than a year so far. I hope someone, in talking to Canon customer service, points out how many posts relate to this problem.

The same issue is happening with my Canon Rebel T3i. It's very frustrating and an expensive repair.

I just noticed I am on an s100 forum.
My apologies.
click here to view the gallery