cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100

sandysorlien
Apprentice

Hello,

I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575

What I have found very strange with my shutter release problem is that for long periods of time, i.e, months, the shutter release will not work then all of a sudden it will start working again. Just recently it has started to work again. This sequence began in 2014 after 2 years of ownership. 

The Deoxit cure (see earlier postings) may give you some temporary relief. Here is my theory as to what is going on. It seems that over time the thin gold plating on the switch contacts wears away, allowing oxides to build up. Repeated shutter presses may wear away the oxide, allowing temporary operation. The level of battery charge may play a role. Deoxit desolves the oxides away, but they come back - especially under high humidity or salt air conditions. If you are nervous about disassembly, try spraying some deoxit in while holding the shutter depressed. That worked for me for a while before I replaced the part. 

Thanks. As I said the camera is intermittant. Now it is not working again. As an experiment I placed the camera under a lamp to provide a heat source for drying out possible moisture. This does seem to work for a little while. I will try the spray when i return home from Germany.

Ante
Apprentice

I bought my part from this page http://www.geissler-service.de/ersatzteilbestellung.html sadly it's only in german but the Email to use is et@geissler-service.de

If you are lucky they still have the part there.

Oh and don't expect a quick reply, for me it came a week after I sent them a mail but after that inital mail it all went smooth.

MsPanic
Apprentice

I have the very same problem. Nothing seems to work and the warranty just expired...

How can Canon say this is not a known problem?

I paid $450 for this camera and its now useless.

PowerS
Apprentice

Dear canon, same problem here... I just registered because of that.
No 4381.....

Hi, I would like to ask, how the part CM1-7226-000 looks? I want to buy it, but I'm not sure I'm able to change it in my camera. It is only shutter button, need I the solder for it? Thank you

Hi Septimus,

No soldering to replace the shutter release. The part does not include the button, which stays on the case. There is a tiny switch and a printed circuit on a flexible ribbon. You can find some photos in earlier posts. It is more like working on a watch than like working on electronics. The important things are: 

Have a system for keeping track of which screws go where - and how things fit together.

Work slowly and carefully on a clean surface - dining room rather than shop. You might need one or two uninterrupted hours.

Be brave. There is a lot of disassembly to get where you need to go. But nothing requiring special skills.

Don't force anything. But the most problematic step is inserting the delicate ribbon connector on the new part into the main socket on the camera. You have to be firm enough to get it to seat, but not so forceful as to cause damage. Review discussions of these matters in earlier posts, and good luck finding the part and installing it.

Posts #'s 361 and 400 will be useful preparation. Everything later is about difficulty finding the part, and rants about Canon.

Thank you very much for answer 🙂

Avatar
click here to view the gallery
Announcements