Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100



I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575

Hi Dan,


thanks for your advice. I have tried it again and even checked the main connector contacts with a magnifier. Everything looks good and I am sure that the main connector is mounted correctly. However no results - also not in replay mode. 

It is really a nightmare.


Still wondering how Canon can allow to fool customers like this and it is not for the first time. Once had a problem with another Canon of my girl friend (PowerShot A540) which showed exactly the same problem like explained in an official Canon service note. The answer from Canon was that my serial number is not affected by the problem..

so there seems to be some kind of systematic in the way Canon is "handling" such issues and thats why this was the last Canon for me. 


The only positive thing about this is that since the camera isn't working I am using my full frame DSLR more often again which is bulky but works - always (it is not a Canon...) 


best regards


Sorry you did not have success Martin Smith. If you had some functionality before disassembly, and now completely dead, then something got damaged or loosened in the process. Or maybe the battery is dead. 

I have tested with two fully loaded idea what it is. 


Recheck your connections, they are small and difficult.  I used tweezers to make sure they were fully in.  Also make sure the replacement board is in the correct location.  the on-off button may not be making full contact.

Where can I find the part??  can't find it on Canon's site?




I registered for this forum for the sole purpose of responding to this thread.  🙂  I ordered the part CM1-7226-000 just before Christmas from Canon Canada (spoke with Mike).  It was $22.39 CAD and shipped from Japan -- part arrived a few days ago.  My husband followed the procedure per post #400 (too chicken to do it myself!  thank you jimpgh for the procedure!) and the camera seems to work again.  It's like having a new camera except I don't get to unbox it!  Anyway, just wanted to chime in that the part is available as of Dec 2015.  Cheers!

Good job team yellowbarn.


Congratulations for your successful repair ! 

I bought a Sony Rx100 (first edition) on saturday 🙂 and so far I am quite satisfied. 



Congratulation! i am thinking about Panasonic LX100. My S100 no longer work b/c of shutter button and tried to fix unsuccessfully. 


Enter for a chance to win