Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100



I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575

I tried to contact Canon to see if they say anything. I don't know if they will fix it for free. Will let you know.

do you know where I can buy the part??




Call Canon parts: 866-481-2569
Request part CM1-7226-000 "FPC ASS'Y TOP" (Flexible Printed Circuit Assembly, top of camera)

Cost is $18 with shipping.


Direction you should go back to page 40, post 400. Watch out of the main connector. Goodluck.

thank you!!!!

Hello all!


Just repaired my S100.

Ordered FPC from Conventa here in Sweden [link removed per forum guidelines]. The price is about the same + domestic shipment.


I want to point that that (relatively) big connector for the Top FPC has a lock (the black part of the connector) and you better release it. Otherwise you may damage the connector (like I did). I managed to fix the connector afterwards but you better release the lock :).


That you everybody for information gathered here!

After a "professional" repair for >100 EUR solved the problem only for a few shots before AGAIN my S100 would not trigger anymore, I decided to try it on my own. 


In Germany you cannot get the replacement part directly from Canon.  WHen I called  Canon they pointed me to this company:


oKam GmbH - Technischer Service
Spengler Allee 11
D-04442 Zwenkau


Tel.     +49 (0) 34203/51803
Fax.    +49 (0) 34203/51804




This worked really quickly.  Cost was 27 EUR incl. shipping.


I followed the detailed instructions of post 400 (kudos!) and it worked like charm.  I also took photographs of the different stages of disassembly and repair.  If this would help anybody, please let me know and I can post them somewhere.


Now the weird part:  I was obviously curious to understand what causes the release switch to fail.  The white polymer cover on top looked dented and I assumed that the switch was damaged by too much pressure.  So I broke the part off the FCB and disassembled it.  To my surprise, I could not find any damage at all!  The middle contact platelet looked slightly darker than the other parts, as if it was oxidized, but the electrical contacts all worked.  Also the mechanics with both trigger levels worked fine and I could not find anything that could explain the malefunction.


Any insights here!?


The fact that cleaning with DeOxit sometimes works for a short while strongly indicates that the overall problem is oxidation of the contacts. When the problem returns I suppose that the cleaning was not thorough enough. Or the switch contacts might have a thin layer of gold to prevent oxidation. That is a common feature for instrument switches. Once that layer wears off, cleaning may only give short-term relief. When the problem is intermittent the user may get in the habit of pressing too hard and deforming some mechanical components of the switch. Perhaps the shutter switch still works when tested with a meter, but may have a high resistance due to oxidation, and the high resistance reduces the voltage enough for the shutter to fail to trigger. Remember, the camera is designed to work with very low current drain. But all of that is just theory, and I would not be surprised if the answer lies elsewhere. My guess is that your "professional" repair consisted of spraying the shutter with cleaner -- which only works for a week or two. So, if you still have the bad switch, try to measure the actual resistance with a high impedance meter. If the resistance is more than a couple of ohms the theory is supported. Then you can disect the switch and examin the contacts directly to look for traces of gold plating, with evidence of wear. I look forward to the next chapter in your investigation. 



I have got the same problem and Canon in Germany is again unwilling to fix this well known and obvious bug. I ordered the spare part and was able to replace it like mentioned in post 400. Thanks to all and especially jimpgh for the help. However after assembly the camera sems to be dead - no reaction at all. Before I was able to make videos and reply fotos and videos (and take pictures from time to time). Could I have damaged something ? Everything went smooth when reasembling the camera... 

So far I did not use this DeoxIT.

Any ideas ?


Thanks and best regards


The most problematic part of the repair is re-connecting the main connector. Try re-seating it.

Martin, take a look at posts 317 and 373. Maybe a little wiggling and added pressure on the main connector will give results. But take your time. No pliers.

click here to view the gallery