Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100



I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575

Nikfrom80s, you have summed it up nicely.
Would you mind sharing your serial number with the community - and hopefully Canon, if a tech advisor is monitoring this site at all.
Adding tags to this effect, as well as S100 in the message bar to the right might also help future owners find this thread.


I got my free repair from Canon for the sluggish shutter problem, after reporting the case to BBB.


I mailed my s100 to Canon factory service center first, and was given a quote of USD160+ for the repair. I called them to argue, and the only thing they could provide was a 30% discount for the cost. And that was after I was transferred to speak with a supervisor. I then immediately filed a online complaint on against Canon I. T. S., Inc., including a link to this forum thread. Two weeks later I got an email and a call from Canon informing that the repair would be complimentary. I already received my camera now and it works like a charm!


A couple of other posts earlier in this thread have also reported that filing to BBB worked. Hope this helps everyone who is still struggling with their s100 shutter.  


Hello Everyone,


I've been having the same shutter release issues with my S100.  Not wanting to spend >$100 to repair a 2 year old camera, and planning on just replacing it, I figured I had nothing to lose, so I decided to try to repair it myself.


I disassembled the camera (it's easier than you'd think as long as you have a very small phillips screwdriver, and are VERY careful), and found that the shutter release uses a small tactile switch located under the actual shutter button.  The switch is mounted to a flex on the top of the camera frame, along with the mode wheel contacts, power and zoom switches.  The flex is mounted solidly to the top of the metal framework of the camera, so the issue is NOT movement of the flex as some have suggested.  It's the switch itself that's the problem.  I held the switch down, and sprayed a very small amount of DeoxIT (a contact cleaner / conditioner used for repairing old radios and the like) into the switch.  Worked the switch several times to distribute the cleaner, and now the shutter release works just fine.  Obviously the issue (at least with my S100) is the low quality switch used for the shutter release.  Not sure how long this repair will last, but for now it’s working just fine.


Ive used DeoxIt for many years now and it is good stuff and wont harm anything either. It is a great cleaner as well as a lubricant.

I was guessing it was the flexible printed circut board that came loose as one of my guesses or the solder joints on the switch. It is only because I have seen and repaired loose FPC's on older powershot models where the frame was bent.



Have you looked closely at those solder joints with a magifying glass before you reassemble the camera?  You should know by working on these things a "flakey" solder joint can be the source too and just by manipulating the switch like you did could be enough to temporarily make it work. Might be a good idea to reheat them again if possible.


If it turns out to be a permanent fix that would be good news for a lot of still does not explain how some people got it to start working by forcing air into those USB ports on the same side as the shutter switch ?


Since you had it open and saw that it is solidly mounted could some of these reported problems be from pushing the shutter button to hard and bending that frame that holds the board with the switch?


Like I said there are a lot of people who are stuck with a broken S100 shutter switch and any other thoughts you might have would be appreciated

I did look at the solder joints, and they looked OK. I also played around with the switch and the flex for a while before I used the DeoxIT, and it didn’t make any difference.  Resoldering on Flex is tricky – a little too much heat, and you’ve got bigger problems than the switch. I figured I’d try the most non-invasive things first.


I have no idea why some people had luck blowing air in the USB ports, though none of the symptoms / solutions make much sense. For instance, once I got my S100 to take the 1st picture after powering up (usually by wiggling the shutter button around a bit), it would suddenly start working, and until I powered it off, would have no issues.  That’s what caused me to originally think it was a settings / firmware issue.


The flex that holds the switches is physically attached to the top of the metal frame of the camera, and it’s a pretty beefy frame for a small camera. It would be difficult to bend that frame by pressing the shutter button – though I’m sure you could if you really tried.  The switch itself, however is just a small two posn tactile PCB mount switch, and could be easily damaged by pressing too hard. If you press the shutter button and feel both of the detents (focus & shutter), then the switch is probably in the correct position, and is probably not physically damaged, though electrically it still might not work.  


Not sure how permanent the Deox solution is going to be. Best solution would be to replace the entire top flex assembly, which I’m assuming Canon is doing, and would be pretty simple if you could get the part. 

I used a different brand of contact cleaner but it it the trick.


Add me to the list.  Almost 2015 and I'm another victim of the delayed-or-not-working shutter after owning this one for more than 2 years.  Feeling pessimistic after reading others' responses re: repair cost ($160?) - no waaaaay I'm paying that.  I'd rather buy another camera, a non-Canon.  <Sigh>.  Sorry, nothing helpful in this message, just adding to the voices that there has been, and still is, a major problem w/ the S100's shutter release.

I understand the frustration. I was looking to buy a canon DSLR next year but the outcome of this situation will definitely make or break my decision to go canon or not. I thought I was decided until now. I have to say the competitive model I was looking at is looking a whole lot better now.


Same issue...


Perhaps some insight that may or may not be confirmed by other users and may or may not help in IDing the underlying issue.


My canon s100 (serial 46xxxxetc) was purchased from amazon Dec 2010 and recently started acting up. The camera focuses but does not take the photo for varying amounts of time and sometimes not at all.


I have discovered that the more steady I hold the camera, the faster it takes the photo- leading me to believe it is a sensor issue. Regardless, it is still VERY annoying, espeically in low light conditions when the camera must be held even more steady for longer periods to begin with. This issue remains when on self timer as well. It would be nice to know if anyone else has noticed this regarding their shutter release problem, and if someone from canon has further insight.


I love this camera and the quality of photos, but this problem is very dissappointing since taking a photo now is almost impossible and renders this nice peice of equipment useless.

hello S2 and I am sorry to hear you are part of the S100 problem pool

Some have reported "lens error" messages in addition to the shutter button problem. Which may or may not be related to what you are saying There have been reported cures, maybe temporary but I do not recall the mention of what you are saying. It could be the beginnings of the lens error issue also. I believe this is the longest thread in this forum so I may have forgotten or overlooked a similar post(s).


Have to tried taking pictures on a tripod with the self timer? That's about as steady as one can get absent a remote shutter switch. It also eliminates the shutter switch from the equation and leaves only the focus and light metering system.


Another contributer is collecting serial numbers to process a complaint as well as prompting Canon to step up to the plate and do what's right for it's customers, many who are or were very loyal.

I suggest you add your serial number to her list, her handle is Angela and you can find her most recent post about 3 or so posts back,

click here to view the gallery