Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100



I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575

Hey guys,

Just a quick update. My camera isn't working after a few hours, only until I give it another "huff" then it will start working again. I'm going to get a friend to use some air blower to give it a solid, uh, huff, to see if that's at least any better.

Angela - would be interesting to see what findings you have for your camera!

tronnebonne you dont have much to lose and I would do the same thing in your postion. Just keep track of the screws and where they came from. Some of them are very small and with differences in size thats hard to detect with the 0.5mm in length and or width.

I'm already anxious to see what you find out.

There was a recent post by socaljd who blew into that AV port and amazingly his camera began to work again. I can only guess that he exerted enough air pressure to push the FPC board back up into postion to where the button now can reach it. An air compressor set at about 15-20 PSI to start might also do the same.

That has been my best guess all along, that board with the switch comes loose in some manner.


best of results and luck to you and be sure to post the results, with pictures perhaps, not taken with an S100 of course.

Me too

Just for clarification, the mod that edited my post name is Tiffany 🙂 But yes I have the same problem as you Angela 😞 And I am very disappointed. 

Good point Ian... I just assumed "lens error" was related to the shutter problem since Canon S100 had an open statement about this problem:


Is the "lens error" they are describing the same as the shutter release not working? 


The camera's defect is that I hold down the button to try and take photos. I used to be able to take them after a second or two. It then took 5-6 seconds. Then 8-9 seconds. Now not at all. I haven't tried to hold down the button for more than a minute (and why should I have to? That's not how a user takes photos. Unless this is a new feature of cameras to make it "fun" for the user to see if they get impatient enough, whether they can take photos first or decide to buy a new camera 🙂 ). 





Yes, TronneBonne and Ian
It is a very "canned" reply. Not even specific to the S100. Considering so many clients have issues with this, you would think it deserves at least a more technical answer!
My issue is as yours - no lens error message appears. No error message at all appears. The shutter release just stops working in heat and humidity. I live in Canada, not the tropics!

Hah! I live in Canada too. So the camera just dies in Canada now or what? 🙂

Hello Forum...
I have the same problem on S100 - the so called premium range 😞
I see that it is a very common problem. Has anyone been offered a free repair by Canon?

I haven't, no...

But have you tried blowing into the right side of your camera where the flap covers the USB ports?

This solution is SocalJD's solution 🙂


Impressive: nearly 2 years and 20 forum pages of the same isolated Canon s100 issue. It appears that Canon will dogde this one and adding my click will be just as ineffective. Ah what the heck, I'll share too...


All functions seem to work properly, except for that pesky and utterly uselss shutter release. Who needs a shutter anyways? I press the shutter, it initates the auto focus yet only fires off intermittently or is super laggy. Haven't notice a particular pattern and tested in all modes - which produces the same uncomical sense of regret and brand abandonment feeling each time. Ashton Kutcher here I come. least I do not have the "lens error" problem, yet.


Serial 4220320xxxxx

Model PC1675

click here to view the gallery