Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF743cdw scanner error- 255,0,0


Hello everyone, I would like to get some help if possible. 

I have already downloaded the scanner patch and it did not work.  

I have Windows 10  home, 64 bit, 

Thank you




Hi Derek,


Welcome to the Canon Forums and thanks for your post!


To have a better understanding of your issue, please let everyone some additional information. That way, the community will be able to assist you with suggestions appropriate for your product.


1.   Is the printer connected via USB or WiFi?


2.   Is the error message in Window 10 or on the MF743Cdw LCD panel?


3.  Are you starting the scan on the on the MF743Cdw LCD panel or in Windows using MF ScanGear?


4.  If starting the scan from the MF ScanGear, is MF Network Scanner Selector is running in the background?


5.  Can you make a copy on the printer?


Any other details you'd like to give will only help the Community better understand your issue!


If this is a time-sensitive matter, our US-based technical support team is standing by at 1-800-OK-CANON (1-800-652-2666) weekdays between 10 AM and 6:30 PM ET.

I am having the same problem with my MF424dw all in one.

Answers to your question:

1.  USB to router--network

2.  error message is in Windows 10

3.  Windows using Toolbox Utility

4.  Not using MF scangear

5.  I can make a copy of the document so machine is connected and functional.


The Toolbox utility was working one moment, then my router went out, and when it came back on, the Toolbox would not work.  Error message 255.0.0.  A window comes up and says there is no scanner connected.  I can scan with the Adobe Tool and with the MS tool, so scanner is connected and working.  But I like the toolbox app more because it gives me the choice of how to save the file:  PDF, JMP, etc. and it allows me to save it in a certain location and name the doc before it saves.  I would love it if we can get it to work again....

I am having the same problem

windows 10

using MF scan utility

was working last month just fine

via wifi and printer and computer are both on same wifi network

I have same problem. July 2021 went from hardwired network now wireless. Scanning has crapped the bed. Printer says I need to "Connect to Computer" and the UI scan utility FAILS with the 255,0,0 error. The UI utility is useless.


hey does anyone respond to these questions?

sadly crickets here......abysmal drivers and support from Canon.... REALLY disappointing code and programming in these printers. very poor Windows support obviously.

Hello Thomasjohnlynch,


The 255,0,0 error it will mean that the computer is not able to reach the scanner connection on the MF743. If you are getting the error, you can try unplugging your router from the power for 5 seconds and then plugging it back in. Once the network is back up, you can try scanning again. If you still get the error, you can try turning off any security software that could be blocking the scanner software.


If you are still unable to perform a scan from the computer, you can uninstall the drivers and perform reinstall so the computer can try detecting the scanner connection. You can download the recommened driver download at the top of the list found in the link HERE. Once the install is complete, you can try scanning again to see if you get the same error.


If you continue to have the issue, I would suggest contacting support at 1-800-652-2666, our agents would be happy to assist and resolve the issue in a more timely manner.



1-800-652-2666 is not a support number.  The message is not supported and only by self help looking on line.

Hello. 1-800-652-2666 is our phone number. That is the number you call for support if you have one of the imageCLASS units mentioned in this thread. You may need to register before calling if you have a different product. You can do that at

Registration is not required for imageCLASS products.