cancel
Showing results for 
Search instead for 
Did you mean: 

MF742cdw driver installation issues

peter_
Apprentice

I've recently taken delivery of an MF742cdw to use in a small office environment.  We unpacked it and connected it to the network, but I've struck an issue trying to install drivers on Windows 10:

  • If I install the "[Windows 64bit] MF744Cdw/MF742Cdw MFDrivers (Generic Plus UFR II / Generic Plus PCL6 / Generic Plus PS3 / Generic FAX / ScanGear)" v6.404 driver pack, I get errors stating I do not have Administrator Privileges and that the driver cannot be installed.
  • My account is an administrator account, and I get the same error if I right-click the installer and "Run as administrator", or if I run it from an administrator Command Prompt.
  • I am able to install an individual print driver with no issues, so I have the print functions working, but I cannot find a standalone scanner driver for this machine and MF Scan Utility won't run without a valid scanner driver installed.

Can anyone point me in the direction of a standalone scanner driver?  Or, is there advice on what might be causing the Admin Privileges issue when installing the driver pack that includes ScanGear?

6 REPLIES 6

Hector
Product Expert
Product Expert

Hello Peter,

The scanner driver is only available in the recommended driver package. If you are getting that error, you can try creating a new admin account or switching to a local admin account on the computer. If you continue to have the issue after switching to a local admin account or creating a new admin account, I would suggest contacting support at 1-800-652-2666. Our agents would be happy to check what might be causing the issue.

Thanks Hector.

Unfortunately, that process really isn't practical for a multi-user office environment.

I've had a call back from Canon business support who agree something is strange when the individual drivers install without issue, and only the multi-driver package has problems.  They are now looking at a solution and I'll post here if it all works out.

astoll
Apprentice

I've got exactly the same problem with trying to install the scanner driver for a MF742Cdw on a new company W10 laptop. My IT dept have double-checked and I definitely have local admin rights and I'm using 'Run as Administrator' to launch the install.

Really need a fix for this as can't use the scanner

Hi @astoll,

I'm not going to be much help, unfortunately.  Canon phone support (after escalation to senior support) confirmed there's no way around the issue.

But, I've tried installing under three scenarios, and here's what I found:

  1. Initially I'd created my user login via a Microsoft 365 account.  The driver install fails with this.
  2. I create a proper Local Admin account.  The driver install works.
  3. Our IT team went through the process of creating a new Domain login (not Microsoft 365 login).  The driver install works.

So it seems like, for me at least, it is specifically an issue related to creating your Windows user via a Microsoft 365 account.

@peter_

That is very useful - I'll pass that on to our IT support guy and see if they can do the same. I assume once you've installed the drivers, it works using your normal 365 login?

Thanks again

To be honest, I didn't switch back tot eh 365 login to test after installation.  Sorry!

 

Announcements
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM