Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF634Cdw USB connected problem and Windows 11


I have a laptop that this printer was on, upgraded to Win11 64 bit Home version from Win 10 64 bit Home, USB connected All in One Printer/Scanner that was working fine till I had to reimage the laptop.   Downloaded the recommended driver MF632CMFDriverV5401WPlsEN, took the laptop off the internet, AV shut down and follow the prompts/instructions in the app, run as a local admin.  Number of times the installer didn't recognize the printer so just went through the app .end.  After fails, uninstalled printer if existed and drivers, repowered the printer etc. as indicated in the instructions .  Couple of times the install worked per-se or so it appeared.  Last install I got it to recognize the printer and installed the driver and everything 'looks good' but printer does not work.  The scanner portion works but the printer doesn't.  Default printer is the Canon Generic Plus UFR II selected and shows ready.  No found printer related entries in events logs.  I've gotten a test page on install but after system rebooted the printer shows everything good except it no longer prints.  I've done the Windows printer diagnostics, checked everything I can find but I cannot get the printer to work.  Irony is I have 2 laptops, both worked prior to reimaging this one.  Other one still will USB connect and print with this same printer, no issues with that one.  Anyone have any ideas on what to fix to get this to print on this system?  I've gone through virtually ever idea I could find online and none have resolved this no-print issue.  Thanks in advance.



Forgot to mention, when sending a printout to the printer it shows ready, it's set as the default printer and you can see the file in the print queue.  One thing though is the printer display shows "Waiting file name" and never changes when the printout are not happening.

Product Expert
Product Expert

Hello Hcbph,

If you are running into the issue while using the printer via USB, You can try removing any registered USB printer connections and then trying the setup again.

  1. While the printer is on and connected, you can press the Windows key and the letter R key at the same time on your keyboard. In the run box that appears, you can type in devmgmt.msc and click OK.
  2. In the window that comes up, you can click on the option for universal serial bus controllers at the bottom. In the list, you can right click on the option for USB printing support and select Uninstall Device.
  3. Once the connection is gone, you can disconnect the printer.
  4. You can reinstall the recommended driver from our Canon USA support site.
  5. Wait until the setup prompts for the cable connection before reconnecting the cable while the printer is on.

Once the setup is complete, you can try printing again to see if it works for you. If you continue to have issues, I would suggest contacting support at 1-800-652-2666. Our agents would be happy to assist.