Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF4450 and Windows 10: Impossible?


Can the ImageCLASS MF4450 printer/scanner (and MF Toolbox software)  just not be used with Windows 10, period? I've tried reinstalling the drivers in Compatibility mode and everything else I know of


Any guidance?


Frustrating, because this printer isn't all that old.


i posted this on as well


previously, i had installed the latest SW and driver, changed the WIA service (steps below), and it fixed the scan issue but i couldn't initiate the scan via the start button on the imageclass (4370dn).  


i haven't done 'extensive' testing but the NetworkUSBScanPatchEN.exe patch from 7/7/2016 appears to have fixed the scan issue on imageclass (4370dn) and i can initiate the scan via start button on the imageclass as well.  


in particular, i recall that if you scan, disconnect computer from imageclass, power off imageclass, power on imageclass, reconnect computer to imageclass, then scan again it wouldn't work.  now it does.  


i listed steps that i recommend for updating SW and drivers as well.  i'll respond back if i run into issues.  but i have a feeling canon finally (a year later) resolved this issue.



steps for changing WIA service (in case the NetworkUSBScanPatchEN.exe patch doesn't fix your scan issue):



  1. Select Start
  2. Enter services.msc
  3. Select the Services Desktop App
    1. Scroll down to Windows Image Acquisition (WIA)
    2. Right-Click Windows Image Acquisition (WIA) and select Properties
      1. Select the General tab
        1. Make sure that the Startup Type is set to Automatic
      2. Select the Log On tab
        1. Select the box next to Local System account
        2. Select the box next to Allow service to interact with desktop
      3. Select the Recovery tab
        1. Select the First Failure drop-down
        2. Select Restart the Service
        3. Repeat for Second Failure and Third Failure
        4. Leave Reset Service After set to 1 minutes
        5. Select the box next to Enable actions for stops with errors
      4. Select Apply then OK
  4. Reboot


steps i recommend to update SW and drivers:


uninstall mf###-###


uninstall canon mf toolbox


install mf####-###


install canon mf toolbox


View solution in original post



Hi, j4450!

So that the Community can help you better, we will need to know exactly which Canon printer model you're using.  At the moment, we do not have any printers in our lineup with the "ImageWriter" name, but we do make a printer called the imageCLASS MF4450.  Is this the one you're using? That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, our US-based technical support team is standing by, ready to help 24/7 via Email at or by phone at 1-800-OK-CANON (1-800-652-2666) weekdays between 8 AM and 8 PM ET (5 AM to 5 PM PT).

Thanks and have a great day!

Yes, ImageCLASS MF4450 Black & White Laser Multifunction Printer Item Code: 4509B021. This one:


My apologies for the error.

any luck with this issue I am experiencing same thing with scanner. can not connect to scanner.

To the Canon Moderator-


How come you have not responded to this question?

It's been months and I'm hoping that you have an official resolution to this issue.



it's not just you.  

a reboot 'should' fix it as there is a 'limitation' that canon is aware of for windows 8 & 10.    

but if that doesn't fix it, some have reported that 1 of the following has fixed it for them:

  1. adding the mf toolbox to their antivirus (e.g. bitdefender) firewall
  2. re-installing the latest available driver 
  3. setting the "RPC (locater)" service to automatic and ending the "Service Host: Windows Image Acquisition" process via Task Manager and 'abandoning data'
  4. restoring their computer to a point prior to a visual c++ install and then disabling the "Windows Update" service


latest available driver:


I have same problem.  After downloading Window 10 version (64 bit) it works occasionally.  Whenever there is a Window update I have to reinstall the ToolBox.  However after the latest update, I cannnot start the ToolBox, it said

"The application has failed to start because its side-by-side configuration is incorrect.  Please see the application even log or use the command-line sxstrace.exe tool for more detail"


Canon image class MF4450 scanner does not work in Windows 10. I've downloaded the driver mny times over. But NO success. Can anyone please HELP in solving this problem.The printer is not very old. It was working well till I upgraded to Win 10. Shld one revert back to Win 8.1



is there a resolution to this ?   my image class 4450 has sucked  for scanning ever since i - up graded to windows 10

i re-down load the soft ware, it works for a day or so & then zip   nada   **bleep**

have to re-load soft ware   same crap, next day it don't work

if i gotta go buy a new scanner it sure won't be cannon


I have the same issue.  I cannot open the Canon MF Toolbox ver4.9 because it says "the application has failed to start because its side-by-side configeration is incorrect. Please see the application event log of us eth command-line sxstrace.exe tool for more details."


I am ussing a ImageCLASS MF4450 on Windows 10.  Prior to windows 10 i was using win 7 and i never had an issue.


Canon ImageCLASS MF4450 Monochrome Laser ‑ Fax / copier