cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon imageCLASS D570 printer stopped scanning

vhaporhenryp
Apprentice

I've been using this printer to both scan and print for 4 years, and it has worked fine up until now.

When I go to scan something, I press COPY/SCAN button, choose "Computer" OK, "Color Scan" OK, and "Confirm Destination" OK. But now, instead of humming away and scanning the item like it used to do, it just says "An error occurred" and an orange "Error" light flashes. Then, when I re-choose "Color Scan" and "Confirm Destination" I get both the green "Processing/Data" light and orange "Error" lights flashing until it ends up with "An error occurred" message, and the orange light stays on. I've tried opening and closing all the parts of the machine, turning it off, unplugging and replugging it, and no change. I tried printing a page (which works fine), but the orange light keeps flashing; and when I attempt a scan, I get the same result described above.

4 REPLIES 4

dexman335
Enthusiast

Because other functions work as intended, I would reach out to Canon Customer Support to determine if the unit would need to be sent in for a repair.

Hector
Product Expert
Product Expert

Hello Vhaporhenryp,

We would be happy to assist with the issue. To provide some feedback or some troubleshooting steps, we would need some additional information. If you could reply to this message with the information below, we can provide some assistance. For a more immediate resolution, you can contact support over the phone at 1-800-652-2666.

  1. What version of the Mac or Windows operating system are you using on your computer?
  2. Are you connecting via USB or is it over a network?
  3. Are you able to scan using the scanner software installed on the computer or do you get an error as well?

taltman
Apprentice

Hi, I'm experiencing this exact same issue. Here's my answer to those questions.

 

1) Mac computer but running a Windows OS
2) Connected via USB
3) Cannot scan from the computer. I tried and got an error message.

taltman
Apprentice

I contacted customer support and did the following - which ended up working to restore my scan function.

1) turn off the scanner/printer
2) restart your computer
3) after it fully boots up, turn on the scanner/printer
4) open MF Scan Utility 
5) make sure that correct scanner/printer is listed in the top right corner
6) under "scan now" select "document"

This should result in you being able to scan and having the scan pop up on your computer like normal. Afterwards, you should be able to scan using the normal process with the printer/scanner. Hope this works for you!

Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.