Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Imageclass 644cdw will not turn on


MacBook Air M1 iOS 13.0.1 (latest OS) first could not find the Color Imageclass 644Cdw.

So checked that it turned on manually. Still no recognition from Mac. I unplugged printer, 5 minutes wait per Canon, then replugged back in. Still no joy. Installed fresh drivers from Canon website. And tried the whole ritual again. This time, the printer is found. Then it says that toner is out - It's been saying it has been expired the whole pandemic. Since I only print just a few pages a month, I thought I would give the toner a quick shake because maybe the toner settled. Powered off and then back on. It still refused to print stating toner empty. So I put the new toner cartridge in. Now, it won't even start up! The last message recorded on my computer says error for an "open door".

Is there an internal fuse/breaker, or power reset? Otherwise, this has been the most expensive 500 sheets I have ever printed in my life.


Product Expert
Product Expert

Hello Who2u30,

If the printer is no longer turning on, you can try unplugging the power cord from the back of the printer and then pressing the power button 10 times while the printer is unplugged. After that, you can try plugging the printer into a different power source and then turning it on. If the printer still does not power on, it would mean the printer needs service. I would suggest contacting support at 1-800-652-2666 or logging into your MyCanon account to check your service options.