cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot Connect MF644Cdw to Mac Via USB

dws2006
Contributor

I have a new Mac mini running Monterey v12.4. I want to connect my MF644Cdw directly to the computer using USB but nothing I have tried works.  I have tried going to the Menu - Preferences - Network - Wired LAN on the printer and it indicates is successfully configures the Wired LAN connection but, it will not print or scan. In fact, the computer does not see the printer and vice versa.  I have to revert back to wireless AirPrint to get it communicate and print/scan. 

I've downloaded & installed the latest drivers from the Canon site. I also tried to install the latest firmware for the printer from the Canon site but the Firmware Update will not install because it says there is no USB connection to the printer. I had the same problem previously with an older Mac mini running Sierra 10.12 and hope this new Mac/OS would solve the problem.  No luck.  

I watched a set-up video on YouTube that indicated during set-up, when installing the drivers, I should get queried as to the type of connection; wired or wireless.  I never see that window. It just says installation successful and I have to go to "Add A Printer" on the Mac which apparently assumes it's a wireless AirPrint setup. I don't want to use wireless but I'm stuck.  Anyone have any ideas.  I'm at a loss.  

3 REPLIES 3

Hector
Product Expert
Product Expert

Hello Dws2006,

The wired lan settings on the printer will be for connecting the printer to a router with an ethernet cable and will not change the USB connection. 

On your Mac, click on the apple in the upper left hand corner of the screen and then click on system preferences. Once in system preferences click on Printers and Scanners. In printers and scanners, you can click the + at the bottom of the list to open the add printer window. If the printer does not appear in the add printer window, it will mean that the computer does not see a cable connection for the printer. The printer should appear via USB even if the drivers are not installed. You can check and make sure the cable is securely connect to the Mac and the USB port on the back of the printer. If the Mac still does not see the printer, you can try another cable or another port on the Mac.

If you continue to have problems, it looks like there is a problem with the Hardware. I would suggest contacting our support team at 1-800-652-2666. Our agents would be happy to check the issue and provide any service options.

 

Thanks Hector, I have tried everything exactly as you describe.  My Mac does not recognize there is a printer connected via USB. I've tried two different known good USB cables with the same results. So, in desperation, I uninstalled all printers, restarted the computer and it magically installed the correct drivers and the printer is working though intermittently.  I've had to reboot 2X in the past 24 hours to keep it working.  While it was connected & working, I attempted to update the Firmware on the printer thinking that may be the problem.  I did this using the lates firmware update available on the Canon website, no dice.  The computer says there is no printer connected (even though I can print to it).  So, I tried to update the firmware from the printer itself, same result. Cannot find a connected computer. So, while there may be a firmware issue, I am unable to update it.

It appears there is something amiss with the printer itself but I am not inclined to spend more money on something that hasn't worked out of the box.  Unfortunately it's no longer covered by warranty. I'll just have to live with it and limp along, rebooting as necessary to keep it working.  I've always been a fan of Canon products but am very disappointed with this printer. When it works, it works great but, I struggled with it from day 1.

My final message on this subject.  I now have to reboot my computer almost every time I want to print to this printer. It is completely intermittent. I have factory reset the printer, uninstalled and reinstalled the drivers. Made sure I have the latest drivers from the Canon site.  I've tried to update the Firmware, can't do it, computer says there is no printer attached.  Printer says there is no network connection yet the Remote UI clearly shows it's connected.  THIS IS THE LAST CANON PRODUCT I WILL OWN in case anyone from Canon cares.  A printer is supposed to be an invisible tool that just works.  This one never has and I spent way too much $$ for this nightmare.

Announcements
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM