Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't update Firmware on MF634Cdw


I have an MF634Cdw and want to upgrade the firmware from 2.29 to 8+.  I've tried from PC and from printer UI.  The UI error says "Job in progress..Wait a moment, then try again."  I've ensured there is nothing in the queue but it still gives an error.  Any advice?  Much appreciated. 



Rising Star
Rising Star

I used to see this sort of thing happen when I tried to look for updates for my church's MF733Cdw back when the building had DSL Internet service. Once we upgraded to high-speed Internet, the issue ceased.

Try power-cycling the printer and attempt another firmware update. If that doesn't work, and the unit doesn't have any complicated optioning/programming, defaulting and starting from scratch might be another avenue to explore.

Product Expert
Product Expert

Hello Rpcalvert,

The issue you are describing would usually point to a poor network connection. If the printer is connect to the network wirelessly, you can try moving the printer closer to the router for a better connection or you can try connecting the printer to your network with an ethernet cable and then trying the firmware update. If you continue to have issues, I would suggest contacting support at 1-800-652-2666. Our agents would be happy to assist with the firmware update.

Rising Star
Rising Star

A slow Internet connection can also impact the ability to upgrade firmware. My church used to have Verizon DSL (7M down/768K up). Updating the 733's firmware was a chore due to persistent errors. This was the case using Wi-Fi AND a direct Ethernet connection (a 5' CAT6A patch cord) to the rear of the modem.

The issue was resolved when the church switched the Internet service from Verizon DSL to Comcast.

Now firmware checks are consistent and never error out.

click here to view the gallery