Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility + Apple Silicon / M1 Mac


EOS Webcam Utility doesn't work with apps like Google Chrome with M1 Macs, but it should be able to easily with some help from Canon.

I recently switched to an M1 powered Macbook Pro from an Intel one and noticed that after installing the utility, it didn't show up as an available camera. Doing some internet searching including on this forum I found the following advice:
1. Use OBS Studio as a virtual camera.
2. Use the x86 version of Google Chrome in Rosetta

Neither of these are a great option though as running OBS is purely band-aid and the x86 version of Chrome in Rosetta has a massive performance hit for me on my machine.

So I decided to do some debugging as to why it wasn't working. (Why does it work in OBS and perhaps some other places but not in Chrome) and it's actually really simple:

Error loading /Library/CoreMediaIO/Plug-Ins/DAL/EOSWebcamUtility.plugin/Contents/MacOS/EOSWebcamUtility: dlopen(/Library/CoreMediaIO/Plug-Ins/DAL/EOSWebcamUtility.plugin/Contents/MacOS/EOSWebcamUtility, 0x0106): tried: '/Library/CoreMediaIO/Plug-Ins/DAL/EOSWebcamUtility.plugin/Contents/MacOS/EOSWebcamUtility' (mach-o file, but is an incompatible architecture (have (x86_64), need (arm64e)))

Chrome (and probably other apps) bail out when they try and grab the device because EWCService / the CoreMediaIO DAL plugin is compiled for x86 instead of ARM.

I don't have access to the source code (the community would help with these issues if you open-sourced it Canon btw 😉) which limits my ability to go further, but my strong theory is without much work if the existing EOS Webcam Utility for Mac was just compiled / available for ARM then it'd work with a bunch more apps. It could be as simple as changing the build target.

Is there a place we can write up tickets for the EOS Webcam Utility team?


EOS webcam utility was released in Asia for Mac silicon. I downloaded this update for my M1 Max and now EOS integration works fine. Nevermind the won't-solve post.

View solution in original post



I use an Apple M1 and I have a 5D Mark IV

in OBS, the webcam function works (although only after a few tries) in teams, the cam is displayed and also worked. no connection can be established in zoom and not easily in discort either... new software with better stability would be really super helpful, possibly also for facetime and other tools with better functions (e.g.) aperture rules


The latest "EOS Webcam Utility Pro Windows / Mac v2.0" seems to work on my M1 Mac Mini and Ventura (13.0.1) (unfortunately only in Rosetta, no Apple Silicon version there yet)

click here to view the gallery