cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

"Cannot playback image" on EOS Rebel T3

mindenroses
Apprentice

Hello, All:

 

I've had this camera for about eighteen months, using the Dane-Elec 4 GB memory card supplied with the camera.  Until going on a recent vacation, both have worked flawlessly.  After shooting numerous photos this time, when I tried to review the images I saw that they displayed as thumbnails with the "Cannot playback image" error message.  When I tried to download, the images saved only as horizontal bands of color.  I've tried a low-level reformat of the card, which doesn't cure the problem.  Questions:  Does this sound like a defective card, or can there be a problem with the camera itself?  Also, the camera went through TSA security screening for the first time.  Can the screening x-rays have damaged the card?

 

Any thoughts and suggestions gratefully appreciated!

 

- Chris Malany

3 REPLIES 3

What did you see when you tried the card with a different camera and the camera with a different card?

Bob
Philadelphia, Pennsylvania USA

Hello, Bob:

 

Regretably, I've only got one camera body and one card [my bad!].  I salvaged the trip using my Samsung cell phone's camera, which was adequate for my purposes.

 

- Chris Malany

Hello, All:

 

I discovered that the problem was nothing more complicated than a defective memory card.  I've bought two new 16 gigabyte cards, so I now have a backup.  And they say there's almost nothing to go wrong with a memory card!  Live to learn.

 

- Chris Malany

Avatar
click here to view the gallery
Announcements