cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

iPhone connection troubles with EOS Rebel T7

cb4242
Contributor

I'm using an iPhone Xr with the latest firmware 15.6.1, connecting to an EOS Rebel T7 in camera access point mode.

My problem is that the phone keeps dropping the wifi connection to the camera.

This seems to be because the phone views the network as having no internet access, so it gives up on that network.  Then it reverts back to another known wifi network - and I've tried deleting known networks or settings things to ask to join, that just makes the phone give up on wifi entirely and change to using cellular data only, nothing seems to convince it to stay connected to the camera.

Is there any workaround for this?  I suspect this is a newer problem with this phone update, this used to work just fine I know I used it a few weeks ago.  Anyone know a phone setting that will let this work?  Thanks!

 

7 REPLIES 7

NatalyaP
Product Expert
Product Expert

Greetings cb4242,

You may check to see if the phone has an option to where it connects to a preferred network that is able to provide internet connection. If so then please disable this option. In case the camera is letting you know that there is no internet connection when connecting to the camera's access point then check to see if there is an option to confirm to stay connected.

Even with no other known network it still disconnects the camera, it would rather have no wifi connection at all than staying connected to this one.

 

The phone is probably connecting to the Internet through the phone service provider’s data connection.  One solution to this issue is for both devices to connect to common WAP that does have an internet connection, such as your home wi-fi network router.

--------------------------------------------------------
"The right mouse button is your friend."

A common network can help with transferring the photos to the phone when I'm home.  Still doesn't address the inability to get the remote app working when there's no common network.

To reiterate:  when the phone connects to the camera's wifi in easy connect mode, the phone gives up and disconnects.  Before disconnecting the phone's wifi setting page says "no internet connection" on the camera's network, so this seems like a probably cause for why the phone disconnects.  Whether the phone can then reach a different network, or no network at all and just use its cellular data, does not seem to impact the phone's decision to keep giving up on the camera's wifi.

Also, for what it's worth, no other apps are open on the phone, so unless its iOS itself nothing I can see is demanding an internet connection at the time, it's odd the phone would be judging my network choices.  Seems to me I need a phone setting to tell it to be more tolerant of the camera's wifi.  Which I understand may not exist.

cb4242
Contributor

Replying to myself as a follow-up...   Installed iOS 16, the problem persists.  😞

Lots of devices use adhoc networks.  Is this a general issue now with iOS, or is the camera not working correctly?  For example, back when I set up my Sonos speakers, I ran the Sonos app, the speaker was an adhoc network, the app connected and sent the speaker my actual wifi info and so on.  The smart speaker didn't have an internet connection, but the phone worked OK.  This is the same thing, right?  Phone changing its wifi from my router to a self-contained device.  Did the phone's behavior change in a recent update in the past weeks?  Or is it particular to this device?  I can't think of anything else to test on and don't want to risk being unable to set up my speakers again if I reset them for a test.

Waddizzle
Legend

What if use the phone’s Wi-Fi hotspot? Also, I would change the settings for switching networks to “ASK”.  This should be done, anyway, for the security of your device’s data.

--------------------------------------------------------
"The right mouse button is your friend."

That's a good idea, but unfortunately didn't work.  It decides the camera network is not something it wants to stay connected to, reverts to no network, then asks if I want to join another network.  Seems it's rejecting the camera on its own merits, not because of something better in the wifi list, that may help debug this.

The phone won't let me into hotspot mode because I don't have that on my phone service, but I fear it would still just do the same thing judging the camera to be insufficient.

Announcements
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
10/14/2022: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
09/19/2022: New firmware version 1.0.4.1 is available for EOS C70
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!