Showing results for 
Show  only  | Search instead for 
Did you mean: 

Rebel t3 has fully Charged battery, but won't turn on....any suggestions?

I have tried two fully charged batteries, but my rebel t3 won't turn is about 4 years has not been dropped or damaged....and I used it about 3-4 weeks ago with no problem. Any suggestions?

I did read in the manual that there are two different batteries......I have no idea where the second one is located or even how big it is.....


My rebel t3i wouldnt turn on! Thougt it was the battery so I bought a new one. Didn't work. Read some post and thought maybe there was a loose connetcion where the battery goes or the memory card. If either one of those isn't secure it won't work. Not the case. It was my memory card, I has switched it from my Nikon to my Canon and it wouldn't work. I put the memory card into my Mac, deleted everything off of it, put the card back in and the camera works fine. Years of using cameras and I guess I am an idiot....but you don't switch memory cards back and forth unless you format them first. MY BAD.



Happy to have finally solved this problem and at no cost..except now I have a back up battery..which isn't a bad thing.



View solution in original post


TCampbell that was amazing advice and IT WORKS!!!! My T3I stop functioning 2 days ago with all the symptoms describe by the other post. I was also ready to and buy a new camera, HOWEVER YOUR ADVICE ABOUT THE USING MEMORY CARD IN NIKON AND CANNON PRODUCT WORKED.


I had Nikon footage on a memory card that i used in my T3I first then Nikon then brought it back to my Rebel and of course it wouldnt function properly. I put a different card in and my cam came back to life.  It absolutley works. Thank you so much for your care and delligence in trying ot get to the root of the issue for quite sometime but sticking with it and posting for people like me who really love my cam. THANKS AGAIN AND KUDOS


My memory card wasn't even switched between different brands, only between two Canons, and seems to have caused the problem, even after trying a new card.  Trying different memory cards until this fix worked turned my very expensive brick into a working machine again.  I can't thank you enough.

Unfortunately mine is still not turning on. I haven't switch cards to another camera or anything - I even put in a new battery and a new card. Still dead. 😞

What have you tried so far?

Ok I got this camera off a friend, I've tried everything suggested but the new battery and it still won't turn. This has stressed me a bit but I'm glad I'm not alone in this issue. Please help with any other suggestions??

@Tlatkielski wrote:
Ok I got this camera off a friend, I've tried everything suggested but the new battery and it still won't turn. This has stressed me a bit but I'm glad I'm not alone in this issue. Please help with any other suggestions??

Take it back to your "friend".

"The right mouse button is your friend."


I had the same problem with a Rebel T3i I bought in October 2012. Very carefully cared, the camera did not suffered any shock or other problem. "Suddenly" it sttoped to work: - no image in the LCD pannel (competely black) and the only signs I could read in the viewfinder were the ISO value, the "busy" lightning if light was poor (and the built-in flah would automactically been raised), and a green dot on the lower right corner.


Contacts and compartments lock checked. Bettery fully recharched. Problem continued.


After reading these posts I formated the memory card in a laptop and the problem was solved 🙂


One week before I inserted the card in Samsung computer to transfer my last pictures takns (not more than a dozen) as I have been doing since I bought the camera. Never happned before. Fortunately, solved - FORMAT THE CARD (please, this is not a shout, it´s a highligt).


I also realized that I forgot to change the sutter from 10 sec to one shot (as I changed it about 10 days earlier).


Many thanks for thos ewho posted suggestions. Leaving in a small town in South America would not be easy to buy a cheap and good battery...



Make sure the pictures Directory on the card is either not there or the default one, I had forgotten had changed it for copy purposes and when I deleted it, it wortked like a charm


1. I switch my EOS 1100d on and nothing happens.


2. I take out the battery, put it back in and switch on again.  Still nothing happens.


3. I take out the battery, blow on the terminals of the battery and the ones in the camera.  I put the battery back in and switch on again.  Hey presto - the camera works perfectly - until I switch it off.


Then, I have to repeat steps 2 and 3.


I've taken it to several camera shops to see if they'd heard of this issue before.  Nope.  They don't believe it happens - until I show them.  Then, this puzzled look sweeps across their faces.


They have cleaned the terminals on the battery and in the camera and still the issue occurs.  They have even put a new battery in and still the issue occurs.


Ideas, please, guys? 


Okay this is GOING TO SOUND RIDICULOUS! But hear me out.


I had this issue where I turned the camera on and it worked fine, I took the SD card out and swaped it for my 32GB one that I had just found after a while. It didn't turn on so I put the battery, which I had just taken off the charger, back on.


A little bit later I put it back in and it WOULD NOT turn on. So this forum said to check these pins in the SD card slot and battery doors, so I did, no broken pins.


Then someone said to try formatting your SD card, so I did (found a weird file... don't know if it was supposed to be there), but it still wouldn't turn on.


I took the SD card out, blew in the slot like a Nintendo cartridge, thought "Wow, if this works I'm going to have to make an account and tell this story", put the card back in, and it turned on fine right away.


try it.

click here to view the gallery