Showing results for 
Show  only  | Search instead for 
Did you mean: 

R5 Freezing up After Firmware 1.5 Update...


I've heard this is an issue, and I experienced it yesterday while shooting some birds. My R5 locked up about 5 times in a row during one session. Each time I took the battery out and it froze repeatedly. Eventually it stopped, but I was not too pleased. Are others having this issue, is canon going to fix it, and is there a way to go back to version 1.4 as an interim solution?



I have had similar problems with an R5 with battery extender while using my 100-500mm ever since I upgraded to firmware 1.5. I am using AI Servo at the time with '*' Set to Eye focus and 'AF ON' set to focus. This problem happens consistently when I am watching a bird for a while and take my finger off the eye focus back button "*" on my camera. I consistently get a crash when the bird starts to move, I press the eye focus. The key is a pause of at least 5 minutes. One work around is the hit the AF On button (Set to focus) first. At one point I made the AF On button my eye focus button, same result. I have tried all the above suggestions with no luck at all. The issue does NOT happen when using any other lens. I had a friend out with me yesterday who had similar problems and then they stopped when he changed his crop factor on the red menu 1. Now no more issues. Try it, since you are probably shooting birds the crop helps. Canon Needs to fix the firmware.

View solution in original post



I just upgraded to 1.5 today and it freezes constantly for me as well. It does it almost immediately when I’m using USB controls on the camera to change settings. It doesn’t seem freeze when I’m using it not under usb control

I just updated above the steps to the fix provided to me by Canon if you want to give it a try.


Ok so I chatted with Canon support today. This was what I was instructed to do:
Reset camera under wrench menu 5 “Basic Settings only”, clear custom functions and custom settings under next menu (camera) 3&5. Turn camera off. Remove battery pack, memory card and lens. Hold down shutter button for 20 seconds. Put battery, memory card and lens back and turn camera back on. I accidentally did not clear custom settings only custom buttons. I have been playing and it seems to be working well at this point. No freezes yet but I won’t have time to put through paces today. I figure if it comes back I will repeat the above while clearing custom settings as i mentioned above I missed that step. Will update this post if I have additional input. I was advised the firmware will of course remain 1.5 after resetting. I won’t get into any technical about what this might or might not be doing as I am just trying to solve this issue with Canons help.

Thanks for your posting. I was traveling and didn't have the benefit of this forum when I upgraded from V1.3 to V1.5. The R5 became very glitchy. It was awful - it locked up/shut off/came back many times per hour, Animal Eye wouldn't track and showed all kinds of boxes instead of the small square boxes.

A friend suggested resetting the camera. I reset "Basic settings" and that cleared up the problems. However, then I had to go through and redo the back button assignments etc so that was accomplished over several days as the need for a particular feature showed itself (like putting the thumb control of the focus spot on the upper right section of the display). 

Resetting the camera and losing all the programmed preferences shouldn't be necessary. But the R5 has shot several thousand images since then without any glitches.


I posted a response below with the method that seems to have saved my problem if you are still having issues.

Thanks. I've only had mine freeze on me the one time so far (froze several times in a row however)...but if it happens again I may try what was suggested. I wonder what the 'fix' does, and whether canon is going to release an update that solves the problem permanently.


I realise one inerestig think... In red menu-under 7 - Image review - set review duration to off and Viefinder review to Disable. Under this settigs I dont have frezzing or locking up on my R5. I hop this will help someone.

Markoney why do you think turning off the image preview will help? Mine still does it even after going back to 1.4. I already had my view finder off and on screen only. I could try to turn off the review but I do want that on. 

I try, and it helps (I never has locking up at 1.4, even Image Review was Enable). I hope Canon will fix this problem, because I need this function sometimes like you do.

That is interesting.  Thanks for sharing.  

click here to view the gallery