cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Odd sound from EOS 7D

Geezer6951
Apprentice

I have an EOS 7D that is well used. Recently purchased a 150-600mm lens (not a Canon). White out practicing with the lens, the camera started occasionally making an odd, mid-tone whining sound that seemed to be coming from from the battery compartment area of the camera body.
Put the lens on my brothers somewhat less well used 7D and the same thing happened.
The sound is not constant and happens (so far) seemingly random.
Has anyone else ever experienced this issue and if so is it something we should be concerned with?
Thank you in advance for any answers y'all can provide

5 REPLIES 5

rs-eos
Elite

How old is the battery? What brand?  If you have a second battery, perhaps use that for a while and see if the sound continues.

--
Ricky

Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers

Waddizzle
Legend
Legend

Make sure the battery is not overheating.  The problem seems like a bad lens. 

--------------------------------------------------------
"The right mouse button is your friend."

Geezer6951
Apprentice

The lens works really well but we have not eliminated it as the source of the noise since it did it on two different camera bodies. Have ordered a new battery but have not yet received it 

If that particular lens is leading to that noise/sound on two different camera bodies, then the lens is probably the issue as Waddizzle mentioned earlier.

--
Ricky

Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers

Yeah that's what we're thinking. 

Avatar
click here to view the gallery
Announcements