Showing results for 
Show  only  | Search instead for 
Did you mean: 

Help, 1Ds MKii Fails to take photo


Heya, this is my first forum post so please please bear with me.

I recently bought a second hand 1Ds Mkii. The camera seemd to function normally for a few months until it suddenly failed to take a photo, the issue is described below.

I can turn on the camera, view photo's on the card, navigate the menus, and change shutter/aperture/ISO/drive mode autofocus etc without any issues.

If I press the shutter, I can hear the mirror flick up and the shutter activate. I have tested this by setting a longer shutter speed of 10s and listening to the camera. Initially after pressing the shutter I can hear a click and again after 10 seconds I can hear another click.

The issue is that after the photo has been taken the camera becomes completely unresponisve, the card access light is constant red. None of the buttons do anything including the off switch (the only way to turn off the camera is by removing the battery).

The photo never gets written to the card and other photo's remain unaffected.

The problem seems to be mostly in the cold in temperatures around 0deg Celcius. This issue is unpredictable. I am using sandisk extreme 16GB sd card. I have tried using a Sandisk extreme CFexpress card with the same results. Formatting the card, or creating a new folder seems to help sometimes.

Is this a common/obvious issue?
Any help would be appreciated. Thanks



What is the status of the battery? Original one from 2005?


Hi, thanks for your response. I have two batteries both giving me the same result. I original canon and 1 newer third party battery. I can’t see this being the issue as the camera function fine until it tries to write to the memory card, i can’t imagine this is the most battery intensive stage. But I may be mistaken. The issue also happens occasionally in the warm.

Lithium-Ion battery or NiMH?

Both are NiMH


Have you tried to perform a refresh with the charger? I can't find the manual but I think it will take 15 hours.

I’ll give this a go, thanks

8,5 hours discharge. Then 2 hours of charge.

I suppose that if the batteries are at the end of their life the discharge time will be just a few hours.

Hi Peter, i have refreshed the batteries twice. It took over 8 hours to discharge. I can use the batteries for 2-3 days shooting for 3 hours a day without an issue. So, the long discharge time and the long battery life I receive out of the camera hopefully indicate the batteries are in good health.

Unfortunately, refreshing the batteries did not solve my issue. The camera occasionally throws an error 99 but sometimes not. I do not believe it is an issue with lens communication as I have cleaned the contacts, the issue is still prevalent with manual lenses. I have tried rotating the manual lens on the mount so it is not “clicked in” to the ef lock as others online suggested. The issue even occurs without a lens. This has got me stumped, thanks for your help.