cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon R6m2 and Pixel 7 Pro - won't wifi connect

sho17
Contributor

I'm at my wits end here. Got a Pixel 7 Pro a few weeks ago and it will not connect to my R6m2 to transfer photos except on the home wifi, which is useless as I'm heading off to Japan in a few days. 

Used to connect no bother to my Huawei Pro 30 when I was out and about, but now it seems to think a password is required. When I used the Connect to EOS Utility to locate a password (which for some reason keeps changing? useless) and use that for the Wifi connection on my phone I get a connection but without internet so the pairing fails. 

I've deleted Canon Connect from my phone, deleted the camera from Connect, reset communication settings on the R6m2...tried everything with a fresh start....and nothing is working. I can get a Bluetooth connection, but not a Wifi to import images. 

What else can I do? Other than throw both blooming devices in the bin and get something else?! 

23 REPLIES 23

shadowsports
Legend
Legend

I'm sorry I haven't provided screenshots yet.  Back to work after 2 weeks in Alaska.  Busier than expected.  I'll shoot for tomorrow.

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

I'm so confused because some people are saying I need a password and some are saying I don't?! As stated I *never* required one when transferring images on my P30 when out and about. Going into the EOS Utility/SSID has been a completely new exercise for me in this troubleshooting process..

I do appreciate you taking the time to help, its just really frustrating because it reads like I'm doing all the right things (and it used to work!) but now isn't

I do not know what steps you are taking.  It should not be complicated.  It sounds like your camera is connected to your home WiFi because it keeps asking for a password.

It should work similar to this video, which I have not watched.

https://youtu.be/lHDbShvBifQ?si=dRxStm8DpQvo87Tb 

I do the following.  I have no Wi-Fi connections defined in the camera.  I connect the camera and phone using Bluetooth, which you say you can do.  It should be downhill from there.

Using your phone, initiate a download of images.  The phone should ask if you want to switch to a faster connection WITH the camera.  Click [YES] and it should be done.

--------------------------------------------------------
"The right mouse button is your friend."

shadowsports
Legend
Legend

Greetings,

I understand. I will post up the photos when I get home tonight.  

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

shadowsports
Legend
Legend

Greetings,

Sorry for the delay.  Here we go 🙂

Sorry for the blur 

First shot of Wireless Menu, all items off

shadowsports_0-1694061877602.png

Turn Wi-Fi On (Just Wi-Fi)

shadowsports_1-1694062027314.png

Only Wi-Fi Is On

shadowsports_2-1694062068429.png

Now Select Wi-Fi Bluetooth Connection, press Set

shadowsports_3-1694062175351.png

Once the above is selected, I turn the Quick Control Dial 1 click to right This is the dial on the back of the camera.  Connect to Smart Phone is selected, press Set

shadowsports_4-1694062567821.png

Since I connected to my Pixel previously, its there.  Although it displays with a Bluetooth icon, we will connect to the camera's Wi-Fi (the only communication method I have enabled)  Press Set to select.  If you don't have saved devices, select add and press set.

shadowsports_5-1694062765200.png

Now use the Quick Control Dial again, to select OK, Press Set.  I know it says Bluetooth, but its not going to use that connection method.

shadowsports_6-1694063050917.png

Now the camera's SSID and password displays > The camera is an access point and broadcasting Wi-Fi  

shadowsports_7-1694063152192.png

Now open the Wi-Fi Settings on your Pixel 7.  Select the Camera's broadcast, and enter the password.  Note, you can do this in the app as well, but this demonstrates connecting the mobile device to the camera.  As soon as you you connect your phone to the camera, the notification bubble "Tap For Options Will Appear"  This is a prompt to start the CC App.  

shadowsports_8-1694063489376.png

Do that and you will be paired. Notice "Wi-Fi Only"

shadowsports_9-1694063806840.png

Select Images On Camera

shadowsports_10-1694063869843.png

The app will use either connection method.  I typically use BT, but either will work.  If you use both, you can use the mobile devices GPS for tagging photos.  I hope this helps.  

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Gojira
Apprentice

Yeah, I've gone though all those steps...it seems like they are talking to each other, I'm seeing everything showing up on the camera and the phone...but it's just not working.  So close....Quite frustrating.  


@Gojira wrote:

Yeah, I've gone though all those steps...it seems like they are talking to each other, I'm seeing everything showing up on the camera and the phone...but it's just not working.  So close....Quite frustrating.  


I posted a link to a YouTube video that shows how the automatic process works.  

Enable both Wi-Fi and Bluetooth.  Establish a connection to Canon Connect using Bluetooth.  On the smart device running Canon Connect, try to download photos from the camera.  THIS is the point when the automatic Wi-Fi connection begins.

Camera Connect should ask if you would like to switch to a faster connection using Wi-Fi.  Select, “Yes/Ok”.  The connection is made within a second or two, and download begins.  All the posted screenshots requesting passwords, device and network names are bypassed.  The data is automatically exchanged across Bluetooth.

”Do you with to use Wi-Fi?”  “Yes.”  It’s Done.

--------------------------------------------------------
"The right mouse button is your friend."

Did you ever get a solution to this? I seem to be having this issue with my Pixel 7 and M200. I want it most to be able to use the remote live view shooting feature. At one point I actually got it to work, both the camera and phone were talking to each other over wifi and I was actually using my phone as a remote monitor and had control of the camera settings. Then, for a reason I don't understand, my phone stopped recognizing the camera again and I haven't been able to get it to work since. 

Waddizzle
Legend
Legend

This really seems to be a problem with the Google Pixel phones.  

I did a web search for “Pixel 7 Pro won’t connect”.  I got all sorts of results about people having both Bluetooth and Wi-Fi issues with their phones not connecting to computers or home wireless access points, and more.  

There were also a few links to Google, Verizon, YouTube, and third parties with fixes and work arounds.  Some of them are over a year old.

https://support.google.com/pixelphone/answer/6183600?hl=en 

--------------------------------------------------------
"The right mouse button is your friend."

Thanks for the tip. I think you may be right. I tried all of this with an iPhone and I worked right away without any of the issues I had been having on my Pixel. I'll check out the link you sent and see if I can figure out a solution from Google's end. 

Announcements