Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon R6 II Interval Shooting freezes when GPS is connected


I just bought the R6 II and during my very first test, the intervalometer froze the camera. I have since done several test and the issue is the same: it gets through only about 10 shots, then the screen goes dark and the camera is unresponsive until the the battery is removed. This is shooting raw, at about 1/80 shutter speed and 30s interval. Lens is RF 24-70 2.8L. Settings are manual focus with IS off. Memory card is UHS-II V90 (Kingston Canvas React Plus 128GB). Factory Canon battery. Latest firmware on both camera and lens.

Upon additional tests, I found out that this issue is happening only when the camera is connected to my phone (Galaxy Note 20) through bluetooth to get GPS. Is this a defect requiring an RMA or service? I'm not sure why this is happening. And it's consistent because I've done several tests now with same results. The Time Lapse doesn't seem to be affected by this.


Product Expert
Product Expert

Hi excelsius,

Thanks for checking in with us.

I wonder if it makes a difference if you adjust the location permissions for our CameraConnect app. You can adjust that by tapping and holding the app icon then go to info and select PERMISSIONS - LOCATION and select ALL THE TIME.

It might also help to delete the CameraConnect app and then install the latest version from Google Play.

Lastly, you could try doing tests when you're shooting JPGs, instead of RAW images. Does that make a difference when connected to your Galaxy Note 20?

Thank you for the specific suggestions.

Location permissions were already set to ON all the time from the beginning. Also, there is no issue with the app reinstallation because this is a brand new installation. I didn't have the app on my phone before I got the camera.

This leaves the last option about JPEGs. I tried that (largest JPEG size) and the camera still freezes. The only thing that works is disabling GPS (seems like I don't have to disconnect the bluetooth from the camera).

The issue with turning off GPS is that I might not remember it, which will mess up my shots. And if I do remember to turn it off, then I might might remember to turn it back on and thus miss out on geotagging. The camera should really work as is.

If you're working for Canon, can you please confirm if this is normal for all R6 IIs? I'm trying to decide if I need to RMA it or send it to Canon to for service.

Product Expert
Product Expert

Thanks for your reply.

Let's check a few more things. On your smartphone, close out of any other apps that are running in the background except for CameraConnect.

In the camera, go to MENU - GPS DEVICE SETTINGS - SELECT GPS DEVICE and make sure that is set to SMARTPHONE.

After you start the interval shooting, make sure that you are not using any Bluetooth remotes or other Bluetooth devices nearby that might interfere.

Make sure that your phone isn't auto-switching Wi-Fi networks to connect with other networks or devices. Check the Wi-Fi settings before you start and after you stop to see if anything changes.

If problems persist, check the images captured to see if they include accurate GPS data. Is there any difference in GPS data if you just do a single shot when connected to your Galaxy Note 20?

Thank you Nick. Some points:

  • I can't really control what apps are running in the background of my phone. I would have to force close some items from memory, which is only a temporary solution and would mess things up. So I'm not sure I follow this instruction or how it can be achieved
  • The GPS in camera has always been set to Smartphone already.
  • Why would other bluetooth devices matter though? The camera can connect only to a single bluetooth device at a time. It is not paired with anything else nearby in any case
  • I can disable wifi on the phone, but this test is done at home, with a very stable wifi. WiFi switching is not an issue
  • I can see if GPS accuracy changes significantly


But a quick update that might change things. I was trying another test just now with the camera connected with bluetooth to the phone, but GPS disabled in the camera this time. The camera still froze, but after over 100 shots. So it doesn't look like a GPS issue but a bluetooth issue, maybe? Does this change your recommendation for testing? I have an upcoming trip in couple days and wanted to see if I can resolve this today/tomorrow.

I'm not a tech, but out of curiosity, have you tried a different card?

I think I did, an old UHS-I card that gave the same issue. I could retry that test later, but not sure why that would matter because Airplane mode seems to not give the same with the current SD card. I'm doing a longer term test of that mode now.

Did a test and out of 112 photos in interval mode, all GPS locations were accurate except 1. This happened to be one of the last shot before the camera froze and GPS was off by a few thousand miles. But this is not happening consistently with each freeze.

In another test, only the first photo contained GPS data and another 4 photos in the middle of the shots. The camera froze after 46 shots this time.