cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon R6 Freezing Up Intermittently

llehmann
Enthusiast

Anybody else having this problem with the Canon R6 freezing up. It usually starts with the camera not focusing. Its also becomes none responsive to mode changes. The on/off button doesnt work. Opening the battery door shuts it off... but still doesn't fix it. Pulling the battery out usually fixs the problem right away. But again... not always and sometimes it take a few battery removals to get it back up and running. 

This has happened while shooting both photo and video. It happens with different lenses. It happens with different memory cards. I can't recreate the problem on command. The camera works 99% of the time. But at least once a wedding shoot, over the period of 6 hours, It freezes up!

In the video below... I was attached to the Ronin gimbal. But it's happened just shooting photos and without the gimbal. Plus, when I open the battery door and try and turn the camera on/off... it still doesn't work. Has nothing to do with that.

I was on firmware version 1.4
I updated the firmware this week to version 1.5.0.
This problem has been happening for a long time... 8 months. Camera is less than a year old.

Again, at last nights wedding... it froze. 

Here is a video that I recorded when it happened.
1. Focus isn't working. Both back button and touch.
2. Display freezes up. You can still see the audio working.

3. On/off doesn't work.

4. open battery door... nothing works.

5. Pull Battery

145 REPLIES 145

shadowsports
Legend
Legend

Guys,

Has anyone tried the new v1.7.0 FW.  Its worth testing.  I don't have an R6 myself.  I started a feedback thread.

R6 New Firmware Release - v1.7.0 - Feedback Thread - Canon Community

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

DhandaNot
Contributor

I have had the same problem. Earlier it was happening quite often. The local Canon tech helped me change the RF EF adaptor and then the problem was not seen for almost a year.

 

But now the problem has returned. I use EF 500 L F4 normally with a TC 1.4. Whenever I use 2 x TC it is frequent.

 

Looks like the power supply across the adaptor is the problem. Yesterday morning I was using just the R6 and 500L but faced the problem again.

My observation is that it happens when I am in animal tracking mode and have used the camera for sometime. It has problem focusing and later just freezes and switching off does not help one has to remove the battery.

I also use Battery Grip with the camera so not sure if there is anything related to that.

Tronhard
Elite
Elite

My first response to anyone having issues is to make sure they are using the latest firmware version for their gear.  In the case of the R6, the latest version is 1.7.0.  I have two R6 units and they both work flawlessly with that firmware.

Another consideration is what lenses are being used with the camera.  I shoot predominantly with RF lenses, but I have also used legacy Canon EF lenses, and Sigma lenses (150-600c and 60-600s) via adapters.  No issues with any equipment.  I am a wildlife photographer who shoots hand-held in available light.


cheers, TREVOR

"The Amount of Misery expands to fill the space available"
"All the variety, all the charm, all the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris

Sent my R6 back to Canin after having tried everything. Was under warranty and entire motherboard needed replaced.  Now works!!  Test was the problem - faulty from day of purchase.

Hi Chris - That may be correct in your case, and I am very glad you had a positive resolution, but it is is not necessarily valid to extrapolate that to others' situations, in part for the reasons I mentioned in my post. 

Using the latest firmware is a valid procedure for any camera or lens, and from any manufacturer.


cheers, TREVOR

"The Amount of Misery expands to fill the space available"
"All the variety, all the charm, all the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris

tseager
Contributor

I've had the R6 for a couple years now and just began experiencing this issue, with the same equipment. I did happen to use animal tracking mode for the first time today, when using an RF 100-400 f/5.6-8, but did have the issue a few days ago. I don't recall what other lenses I was using when this problem first began to be an issue, but was the RF 14-25 f/4.0 IS or RF 24-70 f/2.8 IS

I should add, my shutter release does not work either. Occasionally, a power cycle will clear the issue, but usually, I must yank the battery once or twice. My camera was sent in for an IBIS issue just a couple months ago and passed all tests. 

ehost
Contributor

Has anyone been able to fix this issue? I bought my R6 about two months ago and I am experiencing freeze-ups every now and then. I might have lost a client because of this very issue. I don't have another spare camera to work. I see a ton of complaints and no solution from Canon after two or three years. I have been doing research and have collected preliminary data on more that 40 R6 owners with the same issue. As 40 being the magical number for a class action to be certified, I am contacting class action attorneys to see what recourses we may have. Maybe none, but one of them told me the case looks promising and with further details he is willing to take on the case. I will create a subreddit soon for this issue alone. 

That seems like it may be the only way for Canon to do anything, but then again, tons of people have had issues with the mirrorless hot shoes too and Canon hasn't helped with those either. 

kfearlessphoto
Apprentice

I had to send mine into Canon to have the motherboard replaced on both of my r6's which cost me a couple hundred dollars each plus shipping. Interested in more info if you proceed with a lawsuit. This issue should have resulted in a recall or at the very least free repairs. 

Announcements