Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon R6 Freezing Up Intermittently


Anybody else having this problem with the Canon R6 freezing up. It usually starts with the camera not focusing. Its also becomes none responsive to mode changes. The on/off button doesnt work. Opening the battery door shuts it off... but still doesn't fix it. Pulling the battery out usually fixs the problem right away. But again... not always and sometimes it take a few battery removals to get it back up and running. 

This has happened while shooting both photo and video. It happens with different lenses. It happens with different memory cards. I can't recreate the problem on command. The camera works 99% of the time. But at least once a wedding shoot, over the period of 6 hours, It freezes up!

In the video below... I was attached to the Ronin gimbal. But it's happened just shooting photos and without the gimbal. Plus, when I open the battery door and try and turn the camera on/off... it still doesn't work. Has nothing to do with that.

I was on firmware version 1.4
I updated the firmware this week to version 1.5.0.
This problem has been happening for a long time... 8 months. Camera is less than a year old.

Again, at last nights wedding... it froze. 

Here is a video that I recorded when it happened.
1. Focus isn't working. Both back button and touch.
2. Display freezes up. You can still see the audio working.

3. On/off doesn't work.

4. open battery door... nothing works.

5. Pull Battery

145 REPLIES 145

Thank you, that's really good to know. I am just worried as I won't be able to send it in over the coming summer with events booked already and no stretch of time that I don't need it 😬 At least not until the late fall. I can't afford to rent or buy one in the meantime but it's my main shooter. In any case, I'll see if CPS is available in Canada! Thank you

Not everyone’s camera is the same.  This is why I encourage people to start a new thread.  Sending your camera to Canon for inspection was a good decision.  It is usually the advice that is given after the member is asked to perform a couple basic troubleshooting steps.

If you look closely at the video in the original post, wireless communications is enabled.  

"The right mouse button is your friend."

lol sir or madam... all due respect but it's not the wireless comms. It's the autofocus - or something that triggers it during autofocus-ing specifically. My wireless comms have been off as have most of the people in this thread. I feel like you must have some kind of Canon agenda to prevent people from thinking there is a collective problem that is plaguing many cameras, and that it's better for people to think they have a different simple issue... I get it. You can keep replying that it's the wireless comms, that's fine. I live in an area with limited cell service, and use my camera in those areas too, and have the same problem. 


In my cases of my EOS R & R6 freezing up, I never use wireless wifi enabled, so it has nothing to do with wireless wifi enabled.

Yeah, lol I'm not sure how many times people in this thread can say it, before this poster believes that it's not the wireless comms? I'm sure a couple more wouldn't hurt 😂


As the creator of this thread... I like to see the continued problems this camera is causing! So post away because the lack of support and solutions from Canon suck!

My guess is the same people will reply again and come up with the same excuses we've heard for years on this thread. 

And here we go....

click here to view the gallery