cancel
Showing results for 
Search instead for 
Did you mean: 

Canon R5 and WFT-R10 wired connection

GarySchmid
Occasional Contributor

Hello guys, am having new the R5 with the WFT-R10 grip as I'd love to have my camera connected via ethernet wire (LAN) to my computer.  But it is NOT working on my Macbook Pro 16 (Catalina 10.15.7). R5 and WFT-R10 have both the latest frimware and EOS Utility is the latest version 3.13.10 (.2) as well.

Mac IPv4: 172.16.16.1
WFT IPv4: 172.16.16.2

The LAN connectivity is showing green on my Macbook but when I start EOS Utility nothing happens. The WiFi/LAN pairing should launch but it doesnt. Camera tells me "Coulnd't find target".

When I tried on my Windows laptop it worked on the first try.

Would be very grateful for some help on this, dirves me crazy since 2 days and the happiness over the new camera is almost gone...

Gary

8 REPLIES 8

kvbarkley
Honored Contributor

I suggest you call Canon support.

GarySchmid
Occasional Contributor

I reached out few times to Canon support but the answer was update software/firmware. Which I've done already anyways, still am having the same problem.

Right now I've the R5 connected with USB-C and no extra benefit from the quite expensive battery grip.

Anyone could establish a Ethernet connection?

Thanks

Hi GarySchmid,

 

Thanks for checking in with us.

 

I know it is frustrating when a camera is not establishing the network connection you need, so we'll do what we can to assist.

 

I'm not aware of any issues with the WFT-R10 and Catalina, so let's check a few things. I imagine that you've manually set the IP for your computer, but if not you can do that in System Preferences - Network - Ethernet.

 

Then go back to SYSTEM PREFERENCS then SHARING and check FILE SHARING and MEDIA SHARING.

 

If problems persist, try doing a test where you set up a wireless connection via FTP server, like FileZilla, which you download for free from https://filezilla-project.org. That would help us determine if the issue is specific to the ethernet connection.

 

Illustrated steps to setting up a connection to an FTP server begin on page 59 of the WFT-R10 user manual.

If you don't already have it, you can get it by visiting www.canoneos.com.

 

Once there, click on DRIVERS & DOWNLOADS link on the top right. On the next page that loads, type in your camera name in the search bar. You may need to delete a few characters and type them again if the WFT-R10 does not initially populate below.

 

 

GarySchmid
Occasional Contributor

Thank you Canon for the reply, highly apreciated!

I tried now the sharing ticks as mentioned below but still in EOS Utility the launcher is not regocnising the wired R5.
I had Cataliina and since a while Big Sure, updates the firmware/software on the Canon products but still I can't establish connection on Mac (on PC it works every time).

Yes I set the IP manually to match camera / computer in the same network. In the network preferences I can see the green dot and "connected".

Will try the Filezilla this days. 

Thank you!
Gary

G-7
Occasional Contributor

Better yes ...since the manual and downloading the new software does not fix the issue...Canon needs to spend more time developing a new fix for it !...Not to memntion knowledge agents on the phone that truly understand the usage of the WFT-R10

Calling someone and having read the manual does not fix the issue...Us working photographers know how to read manuals.

Ask yoursef one question...who would buy a $1000 wireless grip...not the guy that goes to best buy .

G-7
Occasional Contributor

Call Canon ? really ? get rid of it ...the WTF-R10 IS A PIECE OF JUNK...no one at Canon seems to know much about it ..and some on the phone l;ine help did even know that they made it ! 

G-7
Occasional Contributor

Same here ...I call Canon anfd they tell me.." WE HAVE TOOO MANNY PRODUCTS...SO THERE IS NO WAY FOR US TO KOWN EVERY ISSUE...SO GOOD LUCK...The EOS R5 is great ...but skip over the wireless connection , you will drive yourself crazy .best to buy a battery grip ...In personally will return the WFT R10 ...THERE IS NO USE FOR IT !!! 

 

 

GarySchmid
Occasional Contributor

Hi guys, I don't know why but after many times trying all the various possibilities in the settings suddenly it worked! My Mac is on 11.5.2. meanhwile. 
To connect for the first time you've to click on EOS Utility in the application folder for some strange reasons, at least only like this it worked for me. After it starts up automatically when connecting. Still once in a while it just doens't connect without any changes in the settings, back to USB-C. Next day it might works again.

In short, it is possible, not as smooth as on a PC, but it is not the ideal combination with Mac.

Good luck!