Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon M6 Mark ii - Cannot take photo or video

As the title states, I just got my very own M6 Mark ii the other day. It turns on, reads that there’s a card and registers that there is a full battery in place. However I can’t take any photos or video!

The challenge is that because it’s such a new camera I can’t find many fixes around for it.

It’s all in manual focus currently, nothing auto is turned on (anything with the word auto I disabled just in case! Haha)

Regardless of the lenses I plug into it the same result occurs.

When I press down on the button to shoot, the icons on the display disappear until I let go again. However, no photo is taken. So it does register a button being pressed?

I am currently all out of ideas and have reset every setting numerous times to see if it would make any difference.


Sorry a bit late joining in ..... Custom menu 3 - "take photo without lens" option enable. 


View solution in original post



Sounds like a faulty battery to me, just because it shows a full battery doesn't mean it's good.

So will getting a new battery allow me to shoot?

If you just got it, then return the whole package. It could be the battery. Or, it could even be the camera.
"The right mouse button is your friend."


Reset it to defaults (Menus under tools). Put it in P mode forget any manual M mode.  Set the ISO to 200. Put the lens in AF and go outside on a sunny day. Take some shots.  If it doesn't work, return it. It is defective.

EOS 1DX and 1D Mk IV and less lenses then before!


What lens(es) are you using on the camera?


I ask because there are a lot of third party, manual-focus-only lenses available in the M-mount that don't connect electronically with the camera (and you mention manual focus). When one of those is on the camera, it doesn't "think" any lens is installed and won't be able to take a shot until you make a setting in the menu.

If using one of those types of lenses, look in the menu for a setting that enables the camera to "shoot wihout lens" (....even though there's actually a lens on the camera... Quite a few people have had easily solved "problems" with the camera, when they first tried to use third party, fully manual lenses and didn't know this setting was necessary.)


I don't have an M6II, but another possibility... some cameras have a "focus trap" method that can be set in the menu. This prevents the camera from taking a shot until focus is achieved. I don't know if the M6II has something like this or not. But it's something you might check.


Further, with these manual focus/manual aperture third party lenses... if those are what you are using... can only be used in certain exposure modes. M (manual, no Auto ISO) and Av (aperture priority auto exposure) should work. I don't know for certain, but it also might be okay with this type of lens to use "M with Auto ISO" (which is no longer "manual"... it's another form of auto exxposure). With these lenses, you cannot use P, Tv or any of the "Scene" exposure modes.


If using a Canon EF-M lens or another lens with electronic connectivity, temporarily remove the lens and check that the electronic contacts on the rear of the lens are clean and clear of any obstructions. If cleaning of those contacts is needed, use a clean, lint free cloth slightly dampened with isopropyl (rubbing alcohol) to wipe them.


Also look at the corresponding pins just inside the lens mount. Those are spring loaded to make good connection with the lens contacts. See if any of them are "stuck" and not extending properly. If you see one (or more) that have gotten stuck to prevent them from connecting with the camera, you might be able to carefully free it up with a toothpick or fingernail. Just be very careful not to touch the camera's image sensor, since it's right next to those electronic contacts and is exposed while the lens is off the camera.


Finally, it may be a problem with the battery or the battery charger... Are you certain the battery is getting fully charged? There should be a battery level indicator on the camrea, which will tell you if the charge is low (other Canon I use also flash a warning when it gets low... I imagine M6II does the same). Low battery might allow some things to function, but not others.


These are just some possibilities. It's also possible that there's some fault with the camera or the lens. If you have tried multiple lenses and the same thing happens with all... it's more likely the camera. Seeing how you just bought it, if none of the above helps I'd recommend contacting the seller about making an exchange. If for some reason that's not possible, contact Canon under the warranty program.


Hope this helps. The M6 Mark II seems like a really nice camera, just reading about it.



Alan Myers
San Jose, Calif., USA
"Walk softly and carry a big lens."
GEAR: 5DII, 7DII (x2), 7D(x2) some other cameras, various lenses & accessories



Sorry a bit late joining in ..... Custom menu 3 - "take photo without lens" option enable. 




Just bought the Laowa 65mm 2x macro and couldnt get the shutter to work. 


This worked like a charm. I love the internet.