cancel
Showing results for 
Search instead for 
Did you mean: 

Canon EOS Rebel T6 showing weird red lines a whited-out areas on photos

totally_a_pro
Apprentice

So I bought my camera around Christmastime in 2017. I have been using it since, taking it almost everywhere I go. I love photography. 

 

However just a couple of days ago I was shooting for a VBS camp when my camera began to show weird red lines over the picture which made the picture very distorted. (I'll attach a picture, I could only attach one but the others looked worse than this)) 

 

What's odd about this is that a couple of moments later, the camera began to take normal pictures again. I figured it must have been some static problem. Then an hour or two later it did it again. Then another time a couple of hours later. It is very annoying and sad that I can't use my camera on a regular basis anymore. Sometimes the pictures turn out fine, and sometimes they don't.

 

It is strange that a camera that is only about a year and a half old would do this. If I have to I will send it in to Canon to see if they can fix it. If anybody has any ideas please let me know. Thanks!IMG_2451.jpg

3 REPLIES 3

Waddizzle
Legend

Try a new memory card that has been formatted in the camera.  I recommend a full size SD card, not a micro-SD card that needs an adapter.  I recommend Sandisk Extreme/Extreme Pro 32 GB.  Do not buy one on Amazon.

Also, try resetting the camera back to factory defaults.  This function only can be found in the menus when you are in a Creative Shooting Mode: P, Av, Tv, M.

--------------------------------------------------------
"The right mouse button is your friend."

Okay. I will try and get a new SD card, and I will update later. Thank you!

You can try a new SD card but when that doesn't help, you need to call Canon 1 (800) 652-2666.  It looks like a sensor failure to me.

EB
EOS 1DX and 1D Mk IV and several lenses!
Announcements