cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 7D Autofocus Broken (will not autofocus)

jjmcchesney
Apprentice

Hi,

 

The autofocus will not work whatever lens I attach to my 7D. On a 70-200mm I hear I whiring noise in the camera and a weak sounding of the lens focusing. 

 

The contacts are clean. I've reset all the camera settings.

 

I can manually shoot and the photos are fine.

 

Any ideas?

 

thanks

 

J.J.

1 ACCEPTED SOLUTION

Thank you so much for replying so quickly! 

 

I solved the problem!

 

I'm going to post this (with shame) so the comunity can learn!

 

I had set up 'back button focus' using the AF-ON button. 

 

I thought 'clear all camera settings' had cleared this. It hadn't. I found you have to use the 'clear all custom func.' menu item!

 

So it was working all along! :

 

Panic for me over. I hope at least I've provided someone with a good laugh today!!!!

 

 

View solution in original post

5 REPLIES 5

jrhoffman75
Legend
Legend
Welcome to the forum.

Please provide some more info.

1. If you move the lens switch to MF and focus manually does the green dot in the viewfinder light up?

2. If you switch to Live View with lens in MF can you focus on the LCD?

3. With lens in AF will the camera focus in Live View?

4. Is the 70-200 lens the only one that makes the noise? Are you sure the noise is in the camera?

5. What are the other lenses that also don’t focus?
John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

jrhoffman75
Legend
Legend
6. Does the situation occur if camera is set to Program mode and One Shot AF with single center focus point?
John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

Nick2020
Product Expert
Product Expert

Hi jjmcchesney,

 

Thanks for checking in with us!

 

Perhaps something is not quite right with your camera, but let's check a few things just in case. Take a few more test shots, keeping in mind the following shooting tips. There's a good chance you already know these principles, but I thought I'd run through them as a sort of quick review.

 

To obtain sharp, accurate images, the shutter button should be pressed halfway to allow the camera to meter and focus. When focus has been achieved, the camera may beep or show a light indicator next to the viewfinder. At that point, the shutter should be depressed fully to take the picture.

 

Keep in mind that the autofocus might not work well in the following situations:

* Subjects with extremely low contrast to the surroundings

* Subjects mixing close and far objects, like shooting a scene through a chain-link fence

* Subjects with extremely bright objects at the center of the composition

* Subjects that are moving quickly

* Subjects in low-light environments

 

To shoot these subjects, first aim the camera at an object at a similar distance, lock the focus and recompose the image with the desired subject, or use the manual focus.

 

If problems persist, I suggest that you email us at eosdigitalsupport@cits.canon.com with details about your camera, your date of purchase, and the state from where you are sending the camera, and we'll walk you through your repair options.

Thank you so much for replying so quickly! 

 

I solved the problem!

 

I'm going to post this (with shame) so the comunity can learn!

 

I had set up 'back button focus' using the AF-ON button. 

 

I thought 'clear all camera settings' had cleared this. It hadn't. I found you have to use the 'clear all custom func.' menu item!

 

So it was working all along! :

 

Panic for me over. I hope at least I've provided someone with a good laugh today!!!!

 

 


@jjmcchesney wrote:

Thank you so much for replying so quickly! 

 

I solved the problem!

 

I'm going to post this (with shame) so the comunity can learn!

 

I had set up 'back button focus' using the AF-ON button. 

 

I thought 'clear all camera settings' had cleared this. It hadn't. I found you have to use the 'clear all custom func.' menu item!

 

So it was working all along! :

 

Panic for me over. I hope at least I've provided someone with a good laugh today!!!!

 

 


I think just about everyone who ever sets up BBF lays that same egg, sooner or later.

--------------------------------------------------------
"The right mouse button is your friend."
Announcements