cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

70D won't turn OFF (Power switch does nothing)

thethanx
Apprentice

So, I've seen a lot of posts about people having the opposite problem, but this one seems new:

 

I recently purchased a 70D and the camera boots up as soon as a battery is put in, regardless of the position of the power switch, then, I can't seem to get it to power off unless I pull the battery. 

 

I've tried clearing all the settings, I've tried reinstalling the firmware... nothing seems to work. Otherwise the camera works fine! I just don't want to have to pull the battery every time I want to shut it off!

 

Any thoughts?

 

 

6 REPLIES 6

Ray-uk
Whiz

Sounds like a mechanical problem with the switch, not too much of a problem as when the camera goes into sleep mode it is virtually off anyway.

Well, it's not a problem unless the camera somehow gets turned off and then I can't turn it back on again.

 

I just purchased the camera (used), and this wasn't listed as an issue, so I'll probably just return it. Thanks

TCampbell
Elite
Elite

You don't happen to run Magic Lantern firmware do you?

 

If not, then you'll want to contact Canon service.  The switch is a software switch (it doesn't actually cut power... it just tells the firmware that you want to power off and the firmware handles the graceful shutdown (e.g. dust removal cycle if needed).

 

So this can be an indication that the camera firmware is locked up (or currupt firmware).  But since you said you re-installed the firmware, it's unlikely that that this is a firmware problem and the camera probably does need service.

 

 

Tim Campbell
5D III, 5D IV, 60Da

I ran ML on a previous camera (a t3i) but never installed it on this new camera. I wondered if the ML firmware would have something to do with it, which is part of why I reinstalled the Canon firmware... but that didn't seem to solve the problem.

 

Is it possible that that had something to do with it? Is there a way to cleanly format the camera?

 

Thanks!

Magic Lantern does nothing to the firmware it only resides on the memory card and provides the extras when it boots up from the card, providing the card has been reformatted then Magic Lantern will have been removed and has nothing to do with your problem.

howlnorth
Apprentice
This just happened to me out of the blue (camera is about a year old) when I put a new Sigma 18-35mm lens on it. Maybe a coincidence it happened at the same time or maybe different lenses can mess with the firmware?
Avatar
click here to view the gallery
Announcements