Showing results for 
Show  only  | Search instead for 
Did you mean: 

70D Wifi was working great, now not so much


I had my wifi all set up with my phone for remote shooting with the EOS Remote. Worked great on two or three outings when I used it. I was very impressed.


Fired it up to use a few days ago and wifi would not turn on at the camera. Reset everything and gave it another shot and still nothing.


Today I was messing with it and noticed that the wifi would come on when in the wifi function menus setting up something but would turn off as soon as I left the menu area.


Yes, wifi is enabled at the camera.


Camera also has been acting a bit on the funny side over the last few times out shooting. Just seemed off and had to turn camera off and back on a few times to get strange things to stop like touch screen not responding or just going blank for no reason (not timed out).



Hello benkmedia,


When shooting with the Wi Fi enabled, the connection should maintain once the initial setup has been performed.  If you are switching modes mid-shoot, this can affect the ability to stay connected.  For example, if you switch from one of the Creative Zone modes (P, Av, Tv M) to fully automatic then the Wi Fi connection will not work.  You would need to be in the Creative Zone mode to work properly.  

If you have a GPS receiver connected or camera hooked to a printer, then the Wi Fi will not work.  Also ensure that the camera Menu is set to Camera Connection mode.  This should allow you to connect without timing out.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I am in a creative zone mode and follow the steps in the manual. Once I leave the initial setup the Wi Fi disconnects. Had the camera looked at and it was the opinion that it is a software issue. I reset everything in the camera and charged up batteries. Seems to be working okay now.


Same thing happened to me. In the middle of a shoot.

Working like a champ, and then suddenly stopped.

Now the camera refuses to do Wi-Fi.

It is only 6 mths old.

My Canon 70D is just 2 yrs old. The wifi was working great in the begginning however, it stopped working last year and never worked since then. It shows wifi off even when I enable it from menu. 😞


I know this is an old thread but I hope this helps.  I was having a wifi problem when I try to connect my iPhone to my 70D as a "Camera Access Point" when I was in the field, for example.


It appears the problem of my iPhone not being able to connect to the 70D only occurs when the 70D wifi is setup with a password (they call it encryption).  If I setup the 70D wifi with a blank password, I have no problem connecting with my iPhone and transfering images via Canon Connect.


Sure, there is no password or encryption but I only leave the camera's wifi enabled only long enough to transfer images to my iPhone then I disable the camera's wifi, primary to save battery power.

click here to view the gallery