cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Tempramental auto-focus on 18-55mm lens

karlcanaries
Apprentice

For some time I have been having issues with my standard kit 18-55mm Canon lens on my Canon 600D camera. Normally when fully extended or contracted, the autofocus works fine but when partially zooming in or out, the autofocus will not work and the screen just flashes. There is no attempt by the lens to focus (no sound or movement) and the screen just keeps flashing. With my 75-200mm lens the autofocus works fine and like I said, works ok on my 18-55 lens when on 18 or 55mm but not when partially zoomed.

3 REPLIES 3

Danny
Moderator
Moderator

Hi, karlcanaries!

So that the Community can help you better, we need to know exactly which Canon camera model you're using. That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

OK thanks, I edited the post stating the camera model.

ebiggs1
Legend
Legend

Try this:

  1. Take the lens off of your camera.
  2. Put the lens in MF mode.
  3. Twist the FOCUS ring (the tip of the lens) all the way to one side (extend it). You may hear a click noise or two, this is good, but don't FORCE the lens.
  4. Twist the FOCUS ring all the way to the opposite side (retract it). Again, you may hear a couple of clicking noises. 
  5. Put the lens back on the camera.
  6. Put the lens in AF mode.
  7. Turn the camera on.
  8. Put the camera in AUTO or P mode.

If this doesn't work it needs professional service. Call Canon 1 (800) 652-2666

EB
EOS 1DX and 1D Mk IV and less lenses then before!
Avatar
click here to view the gallery
Announcements