Showing results for 
Show  only  | Search instead for 
Did you mean: 

TR8520 won't scan after upgrade MacOS to 11.1 (Big Sur)


Had problems with printing and scanning, but solved (I hope) the printer problem.

When attempt to access scan function from System Preferences -> Printers & Scanners->Scan->Open Scanner get message "Failed to open a connection to the device (-21345)"  If connect printer to Mac then click on Open Scanner scanner will run single scan.

Worked fine under Mojave.  Not sure under Catalina, May have worked under original Big Sur and maybe 11.0.1 but definitely does not work under 11.1.  I added IJ Network Device Setup Utility and it says Printer is OK and test print works.  I attempted to install latest Firmware as of Nov. 2020, but it says already have Firmware v. 1.100 installed.When I looked for more recent drivers and other software first got message none for "Catalina (detected)" so Canon doesn't even know I'm running Big Sur.


What do I need to do to get my scanning function back?  


Seems to be the case. Infuriating. I have a relatively newer printer with an older Mac running Big Sur. I can't get it to print or scan. I will NEVER buy a Canon again. They simply don't support their hardware.

Product Expert
Product Expert

Hi ehw,


To resolve the -21345 error, please follow these steps:


1.  From the Home screen, please select the gear icon at the bottom of the display of your PIXMA TR8520


2.  Select Settings


3.  Select Device settings


4.  Select LAN settings


5.  Select Common settings


6.  Select TCP/IP settings


7.  Select IPv6 and then Yes


8.  Select Enable/disable IPv6 and select Disable


9.  Press the Home icon in the upper left corner


Once set, please attempt to scan.






Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
click here to view the press release