Showing results for 
Show  only  | Search instead for 
Did you mean: 

MX 490 continuous power cycling .


My Canon MX490 AIO printer started to power cycle with only the Canon logo showing on the printer display. The printer will move the ink cartridges then the rollers will move and click then shut off then turn back on and start the same cycle again. This will happen while it's plugged in. Any suggestions how to fix this issue?


Hi!  We've released a firmware update to take care of this issue. Learn more now by clicking HERE.

Hope this helps!

View solution in original post


this is what I did which was partly from advice above somewhere. I turned off my router. turned the printer on and the cyling stopped. it was just on. i then turned my router back on and connected like nothing. what started my problem, i think, was renaming my printer while it was off. but def something with the network making it cycle. 

This doesn't work.  I get the error message "the printer can't be found..."  The instructions on the error message don't work since the printer keeps cycling on and off.  I've wasted four hours on this over the last couple of days.  Please send out a fix that works.  

Thanks Danny for the firmware update, it finally has fixed the problem.

NOTE for everybody affected by this issue: you will ONLY need the USB connected to your computer to update the printer, then you can unplug it and your computer will work wirelessly like before.

Problem solved, thank you gain.

I am unable to use the power button to turn off the computer in order to update the firmware.  I'm connected via a USB cable and I unplug - but when I plug back in, I get the following error:  The printer status is incorrect.  Tun on the printer again and then restart utility. 

I have tried this several times.  Unable to download the firmware.


I am using a Chromebook (anyone else?), the new update is for Windows and Mac. So what am I supposed to do? I am still having the exact same issues like everyone else. 


my maxify mb2320 started doing the same thing today



Mine too. I have 2 printers.I had a new one in the box MX490, plugged it in, soon as it was connected to the internet it started the cycle.

Then it seems Canon pushed out a firmware update and messed up everyones printers. They better give us a solution or we all probably need a class action law suit to get new printers or get them fixed.


Same and I can’t even try to troubleshoot/download new software cause the darn thing won’t stop or let me use the menu.


I started the printer without internet access and it started up just fine.