cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MP Navigator and High Sierra

Mike12
Contributor

After installing macOS 10.13.1 (High Sierra) MP Navigator EX 4.0 has ceased to work.

1 ACCEPTED SOLUTION

Thanks, Mark.  In the elegance stakes, that solution scores zero, I'm afraid!  Fortunately, by updating MP Navigator to v4.0.5 and reinstalling the IJ Network Tool in its latest version, all problems with my MG 6150 have been overcome.  Took me a couple of hours to sort that out and I would have hoped for an auto-update from Canon, to be honest, but the job's done, thankfully.  Hopefully this might help other sufferers.

View solution in original post

243 REPLIES 243

Thank you so much Alva, it worked. I had the same problem phoned Canon in UK from Ireland and while they were "trying" to find out, I logged onto Canon Asia as above, down loaded the software and it worked perfectly. You are brilliant and have saved me a fortune. Thank you.

Lucky for you, doesn't work with the MX 800 series

 

Problem appears global, I'm in Sydney

Hi, ran into the same problem with my MX860 after I upgraded to High Sierra recently. I found the correct link to MP Navigator EX Ver. 3.1.5 (Mac) on this forum in a post from waltgoede on 1/5/18.

Here is the link: http://support-th.canon-asia.com/contents/TH/EN/0200328215.html

I installed it and everything is back to normal. I'm on a MacMini late 2012 I7 quad core.  Hope it works for you!

This worked on both of my computers with High Sierra.  I have a 9000F Scanner.  Thanks a bunch.

Doesn't support MX870 printer! Canon drek!!

 

 

Same problem with Canon mp990. Can no longer scan slides. Sorry if this is the wrong place to post this. I am new and can't see how to start a new post.

rick81
Apprentice
I will add that the built-in MacOS Image Capture scanning option does not work over WiFi with the MX860. The drivers in MacOS that automatically load when the MX860 is connected via USB do not work over WiFi. When I follow the MX860 instructions to connect the printer to my network using the Canon IJ Network Tool a new print queue with a MAC address is created. This print queue does not have the scan button like the USB print queue. How are you guys getting the scan button that opens image capture to install in the print queue? I suspect it has something to do with the updated Canon IJ Network tool not locating the scanner selected using the Canon Scanner Selector.

I am able to use Image capture by opening the Image Capture app directly and selecting my MX882 - which appears there by wifi. You are right that the "scan" button doesn't appear anymore through the Printers and Scanners part of System Preferences.

hornfischer
Contributor

Same. With High Sierra 10.13.1 (17B48) installed on my iMac (Retina 5K 27 inch), MP Navigator automatically quits now. I am unable to use my Canon PIXMA MX350 to scan.

 

Searching the Canon site for MX350 software reveals that there are no available drivers. I've been unable to find a new version of MP Navigator on the Canon site either.

 

Help. I have upgraded myself into obsolence.

 

A large company like Canon surely can be expected to stay on top of this. Right?

Sibemommy
Apprentice

I have the  Same problem with the Canon MX860.

Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.