cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MP Navigator and High Sierra

Mike12
Contributor

After installing macOS 10.13.1 (High Sierra) MP Navigator EX 4.0 has ceased to work.

1 ACCEPTED SOLUTION

Thanks, Mark.  In the elegance stakes, that solution scores zero, I'm afraid!  Fortunately, by updating MP Navigator to v4.0.5 and reinstalling the IJ Network Tool in its latest version, all problems with my MG 6150 have been overcome.  Took me a couple of hours to sort that out and I would have hoped for an auto-update from Canon, to be honest, but the job's done, thankfully.  Hopefully this might help other sufferers.

View solution in original post

243 REPLIES 243

Hi stamperlisa,

Thanx for your help and advice. I have got it working too now.

stamperlisa
Apprentice

After reading this thread, I am very diappointed in Canon. My HP printer is 5 years older than my Canon and I have never had a problem with updates. I can't believe that Canon is leaving us high and dry! I have an MP650 and had been happily using MP Navigator EX 3.0 up until the latest Mac update. It's ridiculous that I should have to use a work around for scanning just because Canon doesn't feel like keeping things updated. No work around that I have found is equal to using Navigator - especially when it comes to scanning photos. I guess it's time to retire my Canon and buy another HP - my old HP still works well but it's in use on our secondary computer. 

HowardB
Apprentice
Hi Chielmos, I made sure my MX870 and iMac were both on the same network with the correct printer driver and printed a page to make sure my problem was just with MP Navigator. Then I opened Preview, which is an app in the dock at the bottom of your Mac screen. Now click on the Preview “File” tab, and you should see “Import from Canon MX870 series” as a choice near the bottom of your menu. When you click on that, a window will open for a moment saying “waiting for scanner.” Then you will be able to choose scan mode (flatbed or document feeder) and the other options from the menu on the right. You can choose whether to create a single file or separate file, resolution, duplex scan, etc. MP Navigator was a better solution, but Preview is lots better than nothing. Hope that works for you!

Marc7747
Apprentice

Just got a new iMac. I have a MP970 and it will print with High Sierra using one of the older drivers, but not scan.  I use the scanning for old photo negatives, so it is important to me for the scanning function to work. MP Navigator EX  MP970 series will not download with High Sierra.  Any suggestions,

Hi Mark

 

If you read all the responses to this problem in this thread, you will find that there are a few messy work arounds to get tyour scanner to work. I used the one with Preview, but unless you buy the full version you wind up with watermarks all over your scan. Buying the full version ($40) costs nearly as much as buying a new scanner. So what's the use of that solution. The problem isn't just with your model it is with dozens of older models. I have two different models that now won't work. I haven't read of problems with other major suppliers. So the message is DON'T BUY CANON again and be careful before you upgrade operating systems. Read the users forums and magazine articles to see what issues are being reported.  The other problem is that it is hard to get such problems elevated to a forum with a large readership. This is buried so far down you don't find out until it's too late.

 

The problem seems to be that Canon wants everyone to go buy new multifunction printers rather than fix a problem that should be easy to resolve on their end. The problem is really a Canon problem and they clearly don't care that they are alienating so many existing customers. However, I also fault Apple for not letting people know that once they upgrade their peripherals may not work. They did this for many third party apps re IOS 11 letting people know that many apps might not work with the new system. I for one still haven't upgraded due to both this and the fact that all recent releases of IOS seem to cause more problems that the upgrade is worth. This can be evidenced by the fact that they have had to rush out over 7 updates in just a few weeks and each one fixes some problems and creates more.  But they didn't do this for High Sierra. I haven't found anything in High Sierra that is worth the printer problems it has created.

I agree 100% with waltgoede regarding Apple and the lack of warnings in the High Sierra upgrade, and the nearly nonexistant changes in High Sierra to warrant the headaches outlined in this thread. I mentioned this a few pages back.

Meanwhile, there still is no excuse on Canon's part. There is no replacement printer tht they see that would be a user upgrade worth all the time invested in buying, setup,old printer sell or discard, etc.

 

Are you paying attention Canon??? This is NOT okay. High Sierra has been out for months, and we have heard nothing from Canon as to whether or not we will get relief here. Common sense says that an upgrade is something that can be delivered.

Common business practice and customer service dictates that there is an obligation on Canon's part to communicate at the very least.

 

Canon software writers: Are you waiting for this thread to get to 20 pages?? 30?? Contact Apple and work it out!

Thanks for the reply.  Mine is a new computer that came with 10.13.2 preinstalled, the latest version of High Sierra.  My printer, MP970, WAS capable of scaning 35mm photo negatives and slides and I do use it for that, as well as regular scaning.  I really don't want to have to get another printer/scanner.  I sounds like Canon doesn't care and is not going to upgrade MP Navigator.  I have 3 Canon printers, but only the MP970 does 35mm negatives and slides.  Guess Canon will NOT be my next purchase. 

RachaelTGeorge
Apprentice
Scanner LiDE 210

McFountain
Contributor

Identical problem here: MP Navigator EX 3.0.6 crashes at startup.

MacOS 10.13.2

Canon Pixma MP640

 

MP navigator EX versions 4.0.5 and 5.1.2, don't support my printer

studawg66
Contributor

So I got my MX870 to work with MP Navigator 3.1.5 by doing the following:

 

Go to the canon support site and navigate to where you put in your printer model.  It autodetects the version of OS you are running...mine detected High Sierra.  But click the pull down menu there and select Mavericks.  That will give you an option to download MP Navigator 3.1.5.  Install that and make sure you run the new one it installed (from Launchpad).  Worked just fine for me and scanned like it always has!

 

Not sure if this link will work, but this is the link to that download page I used:

https://www.usa.canon.com/internet/portal/us/home/support/details/printers/support-inkjet-printer/mx...

 

 

Avatar
click here to view the press release
Announcements