Showing results for 
Show  only  | Search instead for 
Did you mean: 

MP Navigator 4 EX no longer working with MacOS El Capitan 10.11.6


Have used MP Navigator 4 to scan for last couple years with MG5220 printer/scanner. Worked fine until a week ago, and I think my Mac OS had a security update, but now MP Navigator 4 crashes on opening. Have uninstalled/reloaded/reinstalled software numerous times with no success. Printer works fine, scanner will work by opening through System Prefs, but can't scan multi page to PDF as I did with the MP Navigator 4. Hate to trash for a new one. Canon, are there any further updates to Navigator that will work with MG5220?



Hi Foghorn5,


I see that you have already updated MP Navigator, so let's also update the drivers.

  1. Click HERE.

  2. Scroll down to "Recommended Drivers."

  3. Click “Select” next to "MG5200 series CUPS Printer Driver."

  4. Press "Download."

  5. Open and run the file.

  6. Follow the onscreen instructions to complete the installation.

The scanner driver can be updated the same way.

This didn't answer your question or issue? Please call or email us at one of the methods on the Contact Us page for further assistance.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


MP Navigator 4 EX still crashes even after reinstalling both the CUPS Printer Driver and the ScanGear MG5200 series driver as instructed.  When I start either the MP Navigator EX 4.0 Opener app or the MP Navigator EX app, the initial Navigator toolbar flashes up midscreen for milliseconds before the "MP Navigator EX quit unexpectedly" screen and error report window displays. This wasn't a problem until very recently. Could there be a conflict with one of the recent OS 10.11.6 updates?

@Foghorn5, I suspect you've fallen into the same hole with MP Navigator that many of us other MacOS users have.
If so, Canon will be no help at all, and their alleged "Product Experts" are low-skilled people sending canned responses.


Even though this thread is for High Sierra, I suspect you may find the answers you need in here, but you'll probably have to slog through all the pages like I did...

JACook, Thanks for the response. I've now figured out the workaround using the SysPrefs Printers and Scanners. Not elegant, but I've managed to make it work until I decide to get a different printer. I didn't update to High Sierra for the very reason of avoiding additional conflicts with other software- but it seems the latest Mac security update for El Capitan did me in. I've always preferred Canon printers--until now. Are you listening, Canon??

Hi Foghorn5,


Although the following article is for macOS v10.13, please try the steps provided:

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Followed all instructions, still having same result of MP Navigator EX 4 quitting. I've tried using both available versions, MP Navigator EX 4.0.4 AND MP Navigator EX 4.0.5 with no success.
Enter for a chance to win